incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ariel Constenla-Haile <ariel.constenla.ha...@gmail.com>
Subject agg broken in configure.in [was Re: Build breaks in module canvas]
Date Mon, 24 Oct 2011 16:49:09 GMT

Hi Pedro,

On Mon, Oct 24, 2011 at 07:02:14AM -0700, Pedro Giffuni wrote:
> This looks like a problem with the new agg and the underlying code
> not being informed by configure that agg_version is now 2400 and
> not being built by default anymore.
> 
> Try doing a fresh new build :(.
> 
> BTW, I hate touching configure but two things to do now are
> enable openldap and disable binfilter by default.

your changes in configure.in regarding agg have some errors:


./configure with default options
---------------

checking whether to enable agg... no
checking which AGG to use... internal

The variable BUILD_TYPE        is set to: OOo CRASHREP BINFILTER ODK
JPEG EXPAT CPPUNIT LIBXSLT LIBXML2 LIBXMLSEC PYTHON BERKELEYDB LUCENE
MYSQLC MYSQLCPPCONN HSQLDB BSH CURL MDDS BOOST VIGRA UNIXODBC SANE ICU
GRAPHITE X11_EXTENSIONS OPENSSL AGG REDLAND LPSOLVE LIBTEXTCAT
LIBTEXTCATDATA GTK SYSTRAY_GTK XPDF SDEXT SWEXT TOMCAT JFREEREPORT
REPORTBUILDER APACHE_COMMONS TOMCAT MATHMLDTD MORE_FONTS AFMS


The variable ENABLE_AGG        is set to: NO
The variable SYSTEM_AGG        is set to: NO
The variable AGG_VERSION       is set to: 2400


Errors:
* ENABLE_AGG=NO but AGG in BUILD_TYPE
* ENABLE_AGG=NO but checking which AGG to use
* ENABLE_AGG=NO but AGG_VERSION set to 2400

************************************************

With --enable-agg
-----------------

checking whether to enable agg... yes

The variable BUILD_TYPE        is set to: OOo CRASHREP BINFILTER ODK
JPEG EXPAT CPPUNIT LIBXSLT LIBXML2 LIBXMLSEC PYTHON BERKELEYDB LUCENE
MYSQLC MYSQLCPPCONN HSQLDB BSH CURL MDDS BOOST VIGRA UNIXODBC SANE ICU
GRAPHITE X11_EXTENSIONS OPENSSL REDLAND LPSOLVE LIBTEXTCAT
LIBTEXTCATDATA GTK SYSTRAY_GTK XPDF SDEXT SWEXT TOMCAT JFREEREPORT
REPORTBUILDER APACHE_COMMONS TOMCAT MATHMLDTD MORE_FONTS AFMS

The variable ENABLE_AGG        is set to: YES
The variable SYSTEM_AGG        is set to: unset
The variable AGG_VERSION       is set to: unset


Errors:
* ENABLE_AGG=YES but AGG_VERSION unset
* ENABLE_AGG=YES but AGG NOT in BUILD_TYPE


Didn't try --with-system-agg because Fedora ships agg 2.5 and 

checking whether to enable agg... no
checking which AGG to use... external
checking for AGG... yes
checking agg version... configure: error: only agg 2.3 and 2.4 are
supported


Regards
-- 
Ariel Constenla-Haile
La Plata, Argentina

Mime
View raw message