incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joost Andrae <Joost.And...@gmx.de>
Subject Re: Fix me: Abnormalities during bootstrap
Date Sun, 11 Sep 2011 15:42:19 GMT
Hi,

after removing the following lines in 
../solver/340/wntmsci12.pro/bin/setup_osl.inf after making a backup copy 
of the original file

File gid_File_Lib_Soactivex
         Dir = gid_Brand_Dir_Program;
         Name = "so_activex.dll";
         Styles = (PACKED);
         UnixRights = 444;
End

and changing the line
  Files = 
(gid_File_Lib_Soactivex,gid_File_Lib_Regactivex_Msi,gid_File_Lib_Regpatchactivex_Msi);

to

  Files = (gid_File_Lib_Regactivex_Msi,gid_File_Lib_Regpatchactivex_Msi);

I was able to successfully build instsetoo_native which produced an 
OpenOffice_archive, an OpenOffice_SDK and an URE installation package. 
The resulting installation works like a charm...hurray!

>> my wntmsci12.pro build has finished but the packaging process stopped due to a missing
so_activex.dll. This is abnormal because I disabled activex build in winenv.set.sh environment
and additionally exported DISABLE_ACTIVEX to TRUE within my Cygwin shell environment.
>>
>> a log snipplet is here:
>> http://pastebin.com/2KFrqG0W
>> ...
>> Any clue how to work-around this ? Perhaps by touching so_activex.dll within the
output tree ?
>
> Looks like we need some additional condition check in
>
> scp2/source/activex/file_activex.scp

I'm so proud about outcome of my lesson about how to make a Windows 
build you cannot imagine...you just have to take the time to do it and 
you'll learn a lot.

It would be a benefit for all people doing a build with the 2008 Express 
compiler if the activex module build logic would be modified in a way 
that the module could be deactivated by environment variable.

Kind regards, Joost


Mime
View raw message