incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rolf Eder <e...@herrmannsdorfer.de>
Subject Re: Build AOOo on Mac OS X 10.7
Date Fri, 30 Sep 2011 10:49:55 GMT
Am 28.09.2011 um 01:00 schrieb Raphael Bircher:

> Hi Chao
> 
> Ok, you have only the 10.6 and 10.7 SDK on board. This explain, why you can't build OOo.
We build OOo agentist the 10.4 SDK. Well, we should try to use a newer SDK anyway, but releases
should be done with a mashine with 10.4 SDK.
> 
> The question at the moment is: "is it possible to build a OOo with 10.4 SDK *and* 10.7
as OS." Clare is, it will work not out of the box.

It is possible.

Following 

http://catacombae.blogspot.com/2011/07/installing-xcode-326-in-mac-os-x-lion.html

I you want to use the 10.4 SDK with Xcode 4.x here is the recipe:

http://hints.macworld.com/article.php?story=20110318050811544 

I have a setup with Xcode 3.2.6, 10.4 SDK running OS X 10.7.1 and can build OOo successfully
(src was fetched Sep 26).

In order to build soltools I just had to remove a disturbing symlink

lrwxr-xr-x  1 root  wheel        17 21 Jul 12:53 /usr/lib/libstdc++.dylib -> libstdc++.6.dylib

which stopped otool and the script.

Tx Pavel for helping me with that.

> Am 27.09.11 19:03, schrieb Chao Huang:
>> hi Rolf
>> 
>> I was trying to use XCode 4.1 on Mac OS X 10.7.

-- 
Rolf Eder
eder@herrmannsdorfer.de






Mime
View raw message