incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Weir <robw...@apache.org>
Subject Re: AOOo can't save passwort protected file
Date Fri, 16 Sep 2011 17:29:34 GMT
On Fri, Sep 16, 2011 at 1:24 PM, Dennis E. Hamilton
<dennis.hamilton@acm.org> wrote:
> I agree that the OO.o 2.4.1 being unable to open the document is not this problem.
>

Is that a typo?  Or are you really debugging this with an OOo 2.4.1
release from 2008?

> It is an indication that something is occurring in the OOo-dev 3.4 package that breaks
down-level compatibility for no apparent reason, and a separate issue (not yet investigated).
>
> I FOUND IT: Beside using <manifest:manifest> manifest:version="1.2",
> OOO-dev 3.4 uses aes256-cbc as the encryption algorithm.  That is going to fail in any
down-level implementation that does not support this allowed but not default encryption.
>
> SUGGESTED TEST:
>
> To see if the Save As with Password problem is related to choice of encryption method
(and what may or may not be in the build), I suggest trying the Save As with Password after
changing Tools | Options | Load/Save | General | ODF format version from 1.2 Extended to 1.2,
> and if that still fails, try ODF format 1.0/1.1 also.
>
> (I can't run that build, or I would do this myself.)
>
> -----Original Message-----
> From: Raphael Bircher [mailto:r.bircher@gmx.ch]
> Sent: Friday, September 16, 2011 01:01
> To: ooo-dev@incubator.apache.org
> Subject: Re: AOOo can't save passwort protected file
>
> Hi Dennis
>
> Thank you for the test too
>
> Am 16.09.11 03:19, schrieb Dennis E. Hamilton:
>> I can't confirm with an AOOo Build, but I did check the OOO-dev 3.4 on win32 to see
if the problem existed previously.  I was able to password protect (encrypt) a simple Writer
document.  It saved and opened fine (after I gave the password again.
> So this is maybe a regression
>> What was interesting to me was that OO.o 2.4.1 (Novell Edition) failed to open the
document and never got to recognizing that it was encrypted.  I got a bad XML message, suggesting
that an encrypted file was being mistakenly opened without decryption first.
> I think, that has nothing to do with it.
>
> Greetings Raphael
>
>
> --
> My private Homepage: http://www.raphaelbircher.ch/
>
>

Mime
View raw message