incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raphael Bircher <r.birc...@gmx.ch>
Subject Re: AOOo can't save passwort protected file
Date Fri, 16 Sep 2011 08:42:38 GMT
Hi Jürgen

Exactly, I used --disable-copyleft wich automaticly use 
--disable-mozilla. Thanks, for your information. I assume that this has 
samething to do with the copyleft removal.

Greetings Raphael

Am 16.09.11 10:30, schrieb Jürgen Schmidt:
> Hi Raphael,
>
> i assume you have built your office with at least --disable-mozilla,
> correct? As far as i know the password encryption used some stuff from the
> mozilla code. So there will be a problem.
>
> Juergen
>
>
> On Fri, Sep 16, 2011 at 10:01 AM, Raphael Bircher<r.bircher@gmx.ch>  wrote:
>
>> Hi Dennis
>>
>> Thank you for the test too
>>
>> Am 16.09.11 03:19, schrieb Dennis E. Hamilton:
>>
>>   I can't confirm with an AOOo Build, but I did check the OOO-dev 3.4 on
>>> win32 to see if the problem existed previously.  I was able to password
>>> protect (encrypt) a simple Writer document.  It saved and opened fine (after
>>> I gave the password again.
>>>
>> So this is maybe a regression
>>
>>   What was interesting to me was that OO.o 2.4.1 (Novell Edition) failed to
>>> open the document and never got to recognizing that it was encrypted.  I got
>>> a bad XML message, suggesting that an encrypted file was being mistakenly
>>> opened without decryption first.
>>>
>> I think, that has nothing to do with it.
>>
>>
>> Greetings Raphael
>>
>>
>> --
>> My private Homepage: http://www.raphaelbircher.ch/
>>


-- 
My private Homepage: http://www.raphaelbircher.ch/

Mime
View raw message