incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 陈京东 <chenjingd...@redoffice.com>
Subject 回复: [WINDOWS-BUILD] Can't successfully build the module of comphelper!
Date Fri, 16 Sep 2011 04:40:45 GMT
Hi all,

About this issue, I have figured out. As Michael said this problem is due to the obsolete
version of mktemp program, I changed my mktemp.exe into the latest version(ver 1.7), error
has disappeared. Here I thank Michael and Eric.b for taking them time to help me!

Regards,

JingDong Chen

2011-09-16

于 2011-9-15 19:25, Michael Stahl 写道:
> On 15.09.2011 07:33, 陈京东 wrote:
>
>    
>> Before building the module of comphelper, everything is ok! but when compiling comphelper
and generating the file - icomphelp.lib, an error occurs, like this:
>>
>> [ build LNK ] Library/icomphelp.lib
>>      
> first, if you have a build problem it always helps to copy the complete
> failed command, not just the abbreviated version.
> i.e. try "cd comphelper&&  make -r"
>
>    
>> mktemp: unknown option -- -
>> Usage: mktemp [-V] | [-dqtu] [-p prefix] [template]
>>      
> that is unusual.
>
> the relevant lines from solenv/gbuild/platform/windows.mk:
>
>    
>> gb_TMPDIR:=$(if $(TMPDIR),$(shell cygpath -m $(TMPDIR)),$(shell cygpath -m /tmp))
>> gb_MKTEMP := mktemp --tmpdir=$(gb_TMPDIR) gbuild.XXXXXX
>>      
> what is the value of $TMPDIR in your environment, or, if it is not set,
> what is the output of "cygpath -m /tmp" ?
>
> it should not contain any spaces, that has always caused problems.
>
> another reason for problems could be that your mktemp is not GNU mktemp,
> or is some outdated version.
> but if you have a recent Cygwin installed that should be used.
>
> what is the output of "which mktemp" and "mktemp --version" ?
>
>    
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message