incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mathias Bauer <Mathias_Ba...@gmx.net>
Subject Re: Fix me: Abnormalities during bootstrap
Date Thu, 15 Sep 2011 22:01:23 GMT
Am 10.09.2011 14:13, schrieb Joost Andrae:

> Hi,
> 
> whilst building wntmsci12.pro my first time ever I saw some quirks that 
> need healing hands:
> 
> bootstrap aquires external files via hg.services.openoffice.org
> 
> I SVN'ed trunk from Apache domain and I think these externals should not 
> use hg.services any more. Would it be possible to move them to an Apache 
> domain based server ?
> 
> After starting the build process on my Win7 64bit notebook (dual core 
> Intel 2.8 Ghz with 8 GB memory) it quite often stopped but rebuilding 
> went always fine (until now; I'm still compiling binfilter). I thought 
> it might be useful to implement a watchdog process watching 
> stderr/stdout that restarts dmake as soon as the build breaks but it 
> needs to interpret the error thrown.
> 
> Documentation at 
> http://ooo-wiki.apache.org/wiki/Documentation/Building_Guide/Building_on_Windows 
> was really helpful despite I had to disable ATL

I have found out that we could get rid of the atl problem. When I was
working on another project that forced me to build Chromium, I found in
their build instructions that the MS Windows Driver Development Kit
contains the necessary atl headers and libs. The WDK can be downloaded
freely, so I assume that it's OK to use them and allow us to build with
VS Express *and* atl.

If someone wants to try it out, here are the instructions for Chromium:

http://www.chromium.org/developers/how-tos/build-instructions-windows

See the "4. If you use Visual Studio 2008 Express:" part.

Regards,
Mathias

Mime
View raw message