incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mathias Bauer <Mathias_Ba...@gmx.net>
Subject Re: [LINUX-BUILD] Details on my Ubuntu 11.04 experience
Date Thu, 08 Sep 2011 17:32:15 GMT
Am 08.09.2011 01:27, schrieb Rob Weir:

> On Wed, Sep 7, 2011 at 5:57 PM, Mathias Bauer <Mathias_Bauer@gmx.net> wrote:
>> Am 07.09.2011 19:27, schrieb Rob Weir:
>>
>>> I did this a couple of days ago, but ran into some issues that others
>>> had not come across, so I decided to repeat it. I wiped out the
>>> machine, and started fresh with new 11.04 Ubuntu machine.  I tried to
>>> follow the build instructions literally and copied errors messages and
>>> remediations when I found them.
>>>
>>> == prep ==
>>>
>>> Fresh install of Ubuntu 11.04 on x86, 1 GB RAM, 240 GB HD
>>>
>>> Ran update manager, installed all patches, rebooted
>>>
>>> == getting the code ==
>>>
>>> We're on Subversion now, not Mercurial, so obviously that part of the
>>> instructions changes.
>>>
>>> svn co https://svn.apache.org/repos/asf/incubator/ooo/trunk ooo
>>>
>>> That didn't work.  Needed to "apt-get install subversion" first.
>>>
>>> Then code downloaded fine
>>>
>>> == build-dep ==
>>>
>>> Instructions in the guide say to do:
>>>
>>> sudo apt-get build-dep openoffice.org
>>
>> Not the instructions that I have pointed to several times:
>>
>> http://wiki.services.openoffice.org/wiki/Documentation/Building_Guide/Building_on_Linux
>>
>> and
>>
>> http://wiki.services.openoffice.org/wiki/Ubuntu_Build_Instructions
>>
> 
> Those are exactly the instructions I used, Matthias.  Take a look at
> them. They say:
> 
> "To make sure that all packages are installed you could just simply run command:
> 
> sudo apt-get build-dep openoffice.org"

So that's wrong. The right thing is what I have once added to that wiki
page:

> sudo apt-get install g++ gcc bison flex libarchive-zip-perl libcups2-dev libpam0g-dev
\
> sun-java6-jdk gperf libfreetype6-dev libxaw7-dev libfontconfig1-dev libxrandr-dev patch
\
> libgconf2-dev libgnomevfs2-dev ant libgtk2.0-dev junit junit4
That worked, last time I checked, with the exeption of librsvg because
of the bug in configure. Sorry for the misunderstanding.

Regards,
Mathias

Mime
View raw message