incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mathias Bauer <Mathias_Ba...@gmx.net>
Subject Re: [LINUX-BUILD] Details on my Ubuntu 11.04 experience
Date Wed, 07 Sep 2011 21:57:06 GMT
Am 07.09.2011 19:27, schrieb Rob Weir:

> I did this a couple of days ago, but ran into some issues that others
> had not come across, so I decided to repeat it. I wiped out the
> machine, and started fresh with new 11.04 Ubuntu machine.  I tried to
> follow the build instructions literally and copied errors messages and
> remediations when I found them.
> 
> == prep ==
> 
> Fresh install of Ubuntu 11.04 on x86, 1 GB RAM, 240 GB HD
> 
> Ran update manager, installed all patches, rebooted
> 
> == getting the code ==
> 
> We're on Subversion now, not Mercurial, so obviously that part of the
> instructions changes.
> 
> svn co https://svn.apache.org/repos/asf/incubator/ooo/trunk ooo
> 
> That didn't work.  Needed to "apt-get install subversion" first.
> 
> Then code downloaded fine
> 
> == build-dep ==
> 
> Instructions in the guide say to do:
> 
> sudo apt-get build-dep openoffice.org

Not the instructions that I have pointed to several times:

http://wiki.services.openoffice.org/wiki/Documentation/Building_Guide/Building_on_Linux

and

http://wiki.services.openoffice.org/wiki/Ubuntu_Build_Instructions

That should have resolved all necessary dependencies (except svn of
course, that wasn't necessary before).

So all other problems you found wouldn't appear, except those:

> 2) checking for external/unowinreg/unowinreg.dll... configure:
> WARNING: not found, will be cross-built using mingw32
> configure: error: for rebuilding unowinreg.dll you need the mingw32
> C++ compiler.
>          Specify mingw32 g++ executable name with --with-mingwin.
>          Or use prebuilt one from
> http://tools.openoffice.org/unowinreg_prebuild/680/ and
>          put it into external/unowinreg

Yes, that should have been mentioned.

> 3) configure: error: requirements to build with librsvg support not
> met. Use --disable-librsvg or install the missing packages

This is a bug in configure, as I already pointed out.

> == bootstrap ==
> 
> ./bootstrap
> 
> This is where I saw references to Hg still, with output like this:
> 
> 24be19595acad0a2cae931af77a0148a-LICENSE_source-9.0.0.7-bj.html
> 2011-09-07 10:53:43
> URL:http://hg.services.openoffice.org/binaries/24be19595acad0a2cae931af77a0148a-LICENSE_source-9.0.0.7-bj.html
> [20335/20335] ->
> "24be19595acad0a2cae931af77a0148a-LICENSE_source-9.0.0.7-bj.html" [1]
> 26b3e95ddf3d9c077c480ea45874b3b8-lp_solve_5.5.tar.gz
> 2011-09-07 10:53:44
> URL:http://hg.services.openoffice.org/binaries/26b3e95ddf3d9c077c480ea45874b3b8-lp_solve_5.5.tar.gz
> [769268/769268] ->
> "26b3e95ddf3d9c077c480ea45874b3b8-lp_solve_5.5.tar.gz" [1]
> 284e768eeda0e2898b0d5bf7e26a016e-raptor-1.4.18.tar.gz
> 2011-09-07 10:53:46
> URL:http://hg.services.openoffice.org/binaries/284e768eeda0e2898b0d5bf7e26a016e-raptor-1.4.18.tar.gz
> [1657246/1657246] ->
> "284e768eeda0e2898b0d5bf7e26a016e-raptor-1.4.18.tar.gz" [1]
> 2a177023f9ea8ec8bd00837605c5df1b-jakarta-tomcat-5.0.30-src.tar.gz
> 2011-09-07 10:53:50
> URL:http://hg.services.openoffice.org/binaries/2a177023f9ea8ec8bd00837605c5df1b-jakarta-tomcat-5.0.30-src.tar.gz
> [3568559/3568559] ->
> "2a177023f9ea8ec8bd00837605c5df1b-jakarta-tomcat-5.0.30-src.tar.gz"
> [1]
> 2ae988b339daec234019a7066f96733e-commons-lang-2.3-src.tar.gz
> 2011-09-07 10:53:51
> URL:http://hg.services.openoffice.org/binaries/2ae988b339daec234019a7066f96733e-commons-lang-2.3-src.tar.gz
> [474681/474681] ->
> "2ae988b339daec234019a7066f96733e-commons-lang-2.3-src.tar.gz" [1]
> 2c9b0f83ed5890af02c0df1c1776f39b-commons-httpclient-3.1-src.tar.gz
> 
> Is this downloading stuff from http://hg.services.openoffice.org/binaries ???  I
> 
> That completes successfully.

Until we will have placed these files somewhere else, we will need to
download it from OOo.

Regards,
Mathias


Mime
View raw message