incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc-Oliver Straub <openoff...@sb-software.de>
Subject Re: [LINUX-BUILD] Developer Education -- Building on Linux event starts now
Date Wed, 07 Sep 2011 10:47:14 GMT
Build succeeded.

RedHat Enterprise Linux 5.6 x86_64 with gcc 4.1.2
Configure switches: --disable-randr --without-junit --disable-mozilla

smoketestoo_native: OK (1)

Problems encountered:
1) configure detects a X11 randr problem and aborts. Need to set 
--disable-randr manually.
2) system-provided gcc slist header file is buggy: need to add the 
following lines to 
/usr/lib/gcc/x86_64-redhat-linux/4.1.2/../../../../include/c++/4.1.2/ext/slist: 
using  std::__true_type; using std::__false_type;

Randr problem details:
checking whether to enable RandR support... checking for XRANDR... no
checking X11/extensions/Xrandr.h usability... no
checking X11/extensions/Xrandr.h presence... yes
configure: WARNING: X11/extensions/Xrandr.h: present but cannot be compiled
configure: WARNING: X11/extensions/Xrandr.h:     check for missing 
prerequisite headers?
configure: WARNING: X11/extensions/Xrandr.h: see the Autoconf documentation
configure: WARNING: X11/extensions/Xrandr.h:     section "Present But 
Cannot Be Compiled"
configure: WARNING: X11/extensions/Xrandr.h: proceeding with the 
compiler's result
checking for X11/extensions/Xrandr.h... no
configure: error: X11/extensions/Xrandr.h could not be found. X11 dev 
missing?

config.log:
configure:17552: checking whether to link to Xrender
configure:17560: result: no, dynamically open it
configure:17564: checking which Xrender headers to use
configure:17580: result: internal
configure:17637: checking whether to enable RandR support
configure:17648: checking for XRANDR
configure:17655: $PKG_CONFIG --exists --print-errors "xrandr >= 1.2"
Requested 'xrandr >= 1.2' but version of Xrandr is 1.1.1
configure:17658: $? = 1
configure:17671: $PKG_CONFIG --exists --print-errors "xrandr >= 1.2"
Requested 'xrandr >= 1.2' but version of Xrandr is 1.1.1
configure:17674: $? = 1
configure:17687: result: no
Requested 'xrandr >= 1.2' but version of Xrandr is 1.1.1
configure:17716: checking X11/extensions/Xrandr.h usability
configure:17716: gcc -c    conftest.c >&5
In file included from conftest.c:56:
/usr/include/X11/extensions/Xrandr.h:49: error: expected 
specifier-qualifier-list before 'Bool'
/usr/include/X11/extensions/Xrandr.h:68: error: expected '=', ',', ';', 
'asm' or '__attribute__' before 'XRRQueryExtension'
/usr/include/X11/extensions/Xrandr.h:69: error: expected '=', ',', ';', 
'asm' or '__attribute__' before 'XRRQueryVersion'
/usr/include/X11/extensions/Xrandr.h:73: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:85: error: expected '=', ',', ';', 
'asm' or '__attribute__' before 'XRRSetScreenConfig'
/usr/include/X11/extensions/Xrandr.h:93: error: expected '=', ',', ';', 
'asm' or '__attribute__' before 'XRRSetScreenConfigAndRate'
/usr/include/X11/extensions/Xrandr.h:104: error: expected '=', ',', ';', 
'asm' or '__attribute__' before 'XRRConfigTimes'
/usr/include/X11/extensions/Xrandr.h:115: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:126: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:127: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:128: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:136: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:137: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:138: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:139: error: expected '=', ',', ';', 
'asm' or '__attribute__' before 'XRRTimes'
/usr/include/X11/extensions/Xrandr.h:147: error: expected ')' before '*' 
token
configure:17716: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE_URL ""
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define SIZEOF_LONG 8
| #define HAVE_LIBCRYPT 1
| #define HAVE_X11_XAW_LABEL_H 1
| #define HAVE_LIBXAW 1
| /* end confdefs.h.  */
| #include <stdio.h>
| #ifdef HAVE_SYS_TYPES_H
| # include <sys/types.h>
| #endif
| #ifdef HAVE_SYS_STAT_H
| # include <sys/stat.h>
| #endif
| #ifdef STDC_HEADERS
| # include <stdlib.h>
| # include <stddef.h>
| #else
| # ifdef HAVE_STDLIB_H
| #  include <stdlib.h>
| # endif
| #endif
| #ifdef HAVE_STRING_H
| # if !defined STDC_HEADERS && defined HAVE_MEMORY_H
| #  include <memory.h>
| # endif
| # include <string.h>
| #endif
| #ifdef HAVE_STRINGS_H
| # include <strings.h>
| #endif
| #ifdef HAVE_INTTYPES_H
| # include <inttypes.h>
| #endif
| #ifdef HAVE_STDINT_H
| # include <stdint.h>
| #endif
| #ifdef HAVE_UNISTD_H
| # include <unistd.h>
| #endif
| #include <X11/extensions/Xrandr.h>
configure:17716: result: no
configure:17716: checking X11/extensions/Xrandr.h presence
configure:17716: gcc -E   conftest.c
configure:17716: $? = 0
configure:17716: result: yes
configure:17716: WARNING: X11/extensions/Xrandr.h: present but cannot be 
compiled
configure:17716: WARNING: X11/extensions/Xrandr.h:     check for missing 
prerequisite headers?
configure:17716: WARNING: X11/extensions/Xrandr.h: see the Autoconf 
documentation
configure:17716: WARNING: X11/extensions/Xrandr.h:     section "Present 
But Cannot Be Compiled"
configure:17716: WARNING: X11/extensions/Xrandr.h: proceeding with the 
compiler's result
configure:17716: checking for X11/extensions/Xrandr.h
configure:17716: result: no
configure:17720: error: X11/extensions/Xrandr.h could not be found. X11 
dev missing?


On 9/6/2011 8:21 PM, Rob Weir wrote:
> As a reminder, the blog post on this event is here:
>
> https://blogs.apache.org/OOo/entry/apache_openoffice_org_developer_education
>
> By my calculations it is already tomorrow in Asia, albeit very early.
>   But it is a good idea to started with the thread.
>
> Those who can help are encouraged to monitor the list as well as
> #dev.openoffice.org on freenode.  As we get reports of issues, respond
> with them on this thread.  We can then go back through the read at a
> later date to pull out issues we can address in the documentation
> and/or the build scripts.
>
> What are we looking for?
>
> 1) Errors in the build instructions
>
> 2)  Errors in the build system that broke due to migration to SVN
>
> 3) Encouraging new developers to start hacking with the code, to grow
> the community
>
> Have fun!
>
> -Rob
>


Mime
View raw message