incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc-Oliver Straub <openoff...@sb-software.de>
Subject Re: Who wants to build OpenOffice?
Date Thu, 01 Sep 2011 09:51:41 GMT
It seems that RHEL5.6 contains a too old version of XRandR:

configure:17552: checking whether to link to Xrender
configure:17560: result: no, dynamically open it
configure:17564: checking which Xrender headers to use
configure:17580: result: internal
configure:17637: checking whether to enable RandR support
configure:17648: checking for XRANDR
configure:17655: $PKG_CONFIG --exists --print-errors "xrandr >= 1.2"
Requested 'xrandr >= 1.2' but version of Xrandr is 1.1.1
configure:17658: $? = 1
configure:17671: $PKG_CONFIG --exists --print-errors "xrandr >= 1.2"
Requested 'xrandr >= 1.2' but version of Xrandr is 1.1.1
configure:17674: $? = 1
configure:17687: result: no
Requested 'xrandr >= 1.2' but version of Xrandr is 1.1.1
configure:17716: checking X11/extensions/Xrandr.h usability
configure:17716: gcc -c    conftest.c >&5
In file included from conftest.c:56:
/usr/include/X11/extensions/Xrandr.h:49: error: expected 
specifier-qualifier-list before 'Bool'
/usr/include/X11/extensions/Xrandr.h:68: error: expected '=', ',', ';', 
'asm' or '__attribute__' before 'XRRQueryExtension'
/usr/include/X11/extensions/Xrandr.h:69: error: expected '=', ',', ';', 
'asm' or '__attribute__' before 'XRRQueryVersion'
/usr/include/X11/extensions/Xrandr.h:73: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:85: error: expected '=', ',', ';', 
'asm' or '__attribute__' before 'XRRSetScreenConfig'
/usr/include/X11/extensions/Xrandr.h:93: error: expected '=', ',', ';', 
'asm' or '__attribute__' before 'XRRSetScreenConfigAndRate'
/usr/include/X11/extensions/Xrandr.h:104: error: expected '=', ',', ';', 
'asm' or '__attribute__' before 'XRRConfigTimes'
/usr/include/X11/extensions/Xrandr.h:115: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:126: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:127: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:128: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:136: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:137: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:138: error: expected ')' before '*' 
token
/usr/include/X11/extensions/Xrandr.h:139: error: expected '=', ',', ';', 
'asm' or '__attribute__' before 'XRRTimes'
/usr/include/X11/extensions/Xrandr.h:147: error: expected ')' before '*' 
token
configure:17716: $? = 1


On 9/1/2011 11:47 AM, Michael Stahl wrote:
> On 01.09.2011 10:33, Marc-Oliver Straub wrote:
>> RedHat Enterprise Linux 5.6 64-bit, gcc 4.1.2
>>
>> ../configure --disable-mozilla --without-junit
>> ....
>> checking whether to enable RandR support... checking for XRANDR... no
>> checking X11/extensions/Xrandr.h usability... no
>> checking X11/extensions/Xrandr.h presence... yes
>> configure: WARNING: X11/extensions/Xrandr.h: present but cannot be compiled
>> configure: WARNING: X11/extensions/Xrandr.h:     check for missing
>> prerequisite headers?
>> configure: WARNING: X11/extensions/Xrandr.h: see the Autoconf documentation
>> configure: WARNING: X11/extensions/Xrandr.h:     section "Present But
>> Cannot Be Compiled"
>> configure: WARNING: X11/extensions/Xrandr.h: proceeding with the
>> compiler's result
>> checking for X11/extensions/Xrandr.h... no
>> configure: error: X11/extensions/Xrandr.h could not be found. X11 dev
>> missing?
>>
>> Adding --disable-randr to the configure flags succeeds.
> you'd need to look at the config.log to see why it couldn't use the
> Xrandr.h.
>
> perhaps some package is missing that we don't explicitly check for.
>
>> However, I see the following error in the configure output:
>> The variable COMMON_BUILD_TOOLS is set to: $SRC_ROOT/external/common
>> Use of uninitialized value in string eq at ./set_soenv line 1987.
>> The variable TMPDIR            is set to: /tmp
> seems to be this test:
>     if ( $ENV{"TMPDIR"} eq "" ) {
>        ToFile( "TMPDIR",      "/tmp",               "e" );
>     } else {
>        ToFile( "TMPDIR",      "$ENV{'TMPDIR'}",     "e" );
>     }
>
> perhaps somebody who knows Perl could rewrite this so it doesn't give a
> spurious warning...
>


Mime
View raw message