incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From eric b <eric.bach...@free.fr>
Subject Re: [LINUX-BUILD] Developer Education -- Building on Linux event starts now
Date Wed, 07 Sep 2011 19:08:39 GMT
Le 7 sept. 11 à 19:10, Michael Stahl a écrit :

> On 07.09.2011 13:49, eric b wrote:
>> Hi Michael,
>>
>>
>> thanks for your feedback :)
>
> hi Eric,
>
> sorry, apparently i was writing in too much of a hurry earlier  
> today to mention that i had already committed my (partial) fix to SVN.
>

Ok.


> it's almost the same as yours, except i've taught gbuild to live  
> without RepositoryFixes.mk (empty one is kind of pointless), and the
> Repository.mk is in extras/l10n.
>

You're right :-)


>> On my side, I'm testing something who seems to work, but I need
>> confirmation (build in progress on Windows). The idea was triggered
>> by Fabien Dobat remark (a student trying to build with me), because
>> of a bad  gb_REPOS
>>
>> then I found two issues, one in set_soenv.in and one in solenv/inc/
>> settings.mk
>
> and i've completely overlooked settings.mk; guess my build will be  
> only partially localized then :)
>
>> If I add the files and the instructions Pavel Janik told me, I got a
>> build who started, and a l10n directory found (remains a strange
>> issue in comphelper though).
>>
>>
>> See:  http://ftp.educoo.org/home/ericb/patches/apache_ooo/ 
>> sources_trunk/
>
> are you a Committer?


Yes, I am.


>
> if yes. please commit the following from your patch (the rest  
> should be in SVN already):
>


Just back, I see Pavel and Eike commited something, and I'll test it  
tonight, or tomorrow (I'd like to see a fr build on Windows   ^^  )




> Index: main/solenv/inc/settings.mk
> ===================================================================
> --- main/solenv/inc/settings.mk	(revision 1166043)
> +++ main/solenv/inc/settings.mk	(working copy)
> @@ -810,7 +810,7 @@
>
>  .EXPORT : SOLARBINDIR
>
> -L10N_MODULE*=$(SOURCE_ROOT_DIR)/l10n/l10n
> +L10N_MODULE*=$(SOURCE_ROOT_DIR)/extras/l10n
>  ALT_L10N_MODULE*=$(SOLARSRC)$/l10n_so
>
>  .IF "$(WITH_LANG)"!=""
>
>
>> 1) put and apply the patch from the same location (as the same level
>> as main and extras
>> 2) copy source_config
>> 3) copy the Repository*.mk inside extras
>>
>> Thanks to Pavel Janik for his help and his patience  :-)
>
> sorry for having duplicated your work :)
>


No problem, really : the essential is to see --with-lang= usable, and  
glad to see things progress. The only remaining issue for me is that  
I need source_config, but maybe a Windows specific issue.


Regards,
Eric

-- 
qɔᴉɹə
Education Project:
http://wiki.services.openoffice.org/wiki/Education_Project
Projet OOo4Kids : http://wiki.ooo4kids.org/index.php/Main_Page
L'association EducOOo : http://www.educoo.org
Blog : http://eric.bachard.org/news






Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message