incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pedro F. Giffuni" <giffu...@tutopia.com>
Subject RE: How to do with glibc-2.1.3 in AOOo?
Date Thu, 15 Sep 2011 01:16:38 GMT


--- On Wed, 9/14/11, Dennis E. Hamilton <dennis.hamilton@acm.org> wrote:
..
> Backing up a little.  I don't
> know if the original BSD license is a problem for Apache,
> but it becomes a problem downstream, so it is good to avoid
> having to carry that license and a NOTICE file about it
> around in Apache OOo.
>

Well, having both we obviously choose the less restricted.

 
> LESS RELEVANT: I've been looking for a good getopt( ) for
> my own use on some other projects, and the Todd Miller
> versions seems to be a good starting point.  It is not
> what I would use, but I would use it as a compatibility
> check.
>

If you want to use the standard version you should compare
against this:
http://pubs.opengroup.org/onlinepubs/009695399/functions/getopt.html

of course you can customize it but then I'd suggest renaming it
to something else. 

> Question: Is it always sufficient to be limited to char[]
> or would a w_char[ ] or even UTF-8 version be more suitable
> these days?  Just curious.
>

For command line options I think the normal char is enough
but if you have special needs I guess you can customize it.
Again I would avoid namespace conflicts with libc.

cheers,

Pedro. 


Mime
View raw message