incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis E. Hamilton" <>
Subject RE: AOOo can't save passwort protected file
Date Fri, 16 Sep 2011 17:30:57 GMT
Oh, there is another bug in Save As with Password. You can't turn it off in saving the opened
encrypted document to a new file with the Password checkbox cleared.  It saves the document
with password anyhow and has automatically reused the same password (very naughty).

[Now I know where LibreOffice got this bug.]

Just for the record.  I must do some bugzilla issues after brunch.

 - Dennis

-----Original Message-----
From: Dennis E. Hamilton [] 
Sent: Friday, September 16, 2011 10:25
To: ''
Subject: RE: AOOo can't save passwort protected file

I agree that the OO.o 2.4.1 being unable to open the document is not this problem.  

It is an indication that something is occurring in the OOo-dev 3.4 package that breaks down-level
compatibility for no apparent reason, and a separate issue (not yet investigated).

I FOUND IT: Beside using <manifest:manifest> manifest:version="1.2", 
OOO-dev 3.4 uses aes256-cbc as the encryption algorithm.  That is going to fail in any down-level
implementation that does not support this allowed but not default encryption.  


To see if the Save As with Password problem is related to choice of encryption method (and
what may or may not be in the build), I suggest trying the Save As with Password after changing
Tools | Options | Load/Save | General | ODF format version from 1.2 Extended to 1.2,
and if that still fails, try ODF format 1.0/1.1 also.

(I can't run that build, or I would do this myself.)

-----Original Message-----
From: Raphael Bircher [] 
Sent: Friday, September 16, 2011 01:01
Subject: Re: AOOo can't save passwort protected file

Hi Dennis

Thank you for the test too

Am 16.09.11 03:19, schrieb Dennis E. Hamilton:
> I can't confirm with an AOOo Build, but I did check the OOO-dev 3.4 on win32 to see if
the problem existed previously.  I was able to password protect (encrypt) a simple Writer
document.  It saved and opened fine (after I gave the password again.
So this is maybe a regression
> What was interesting to me was that OO.o 2.4.1 (Novell Edition) failed to open the document
and never got to recognizing that it was encrypted.  I got a bad XML message, suggesting that
an encrypted file was being mistakenly opened without decryption first.
I think, that has nothing to do with it.

Greetings Raphael

My private Homepage:

View raw message