incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eike Rathke <...@erack.de>
Subject Re: [code] stuck at offapi on unxlngx6.pro
Date Sun, 28 Aug 2011 21:14:37 GMT
Hi Michael,

On Sunday, 2011-08-28 22:30:44 +0200, Michael Stahl wrote:

> > Compiling: Forms.idl
> > ../../../../com/sun/star/ucb/Content.idl(296) : Illegal syntax following service
member declaration: syntax error, unexpected IDL_IDENTIFIER
> i have had the exact same problem trying to build OOO340m1 on my Fedora
> box.  for now i've just worked around the problem by removing the big
> 100s-line comment in Content.idl, then invoking "build" in offapi, then
> putting the comment back.

Well, that's an attempt worth to be tried :-)

> strangely it only happens when building files
> that include Content.idl, not with Content.idl itself.

Indeed.

> guess it's some bug in idlc, or perhaps a compiler bug (gcc 4.6.0 here).

gcc 4.6.1 here, but building LibreOffice no problem, though compiler
options are probably different, Content.idl is nearly identical except
header guards removed (hmm.. I could try that) and corrected typos in
the documentation comments (does idlc now bail out on those if file was
included? ;-)

  Eike

-- 
 PGP/OpenPGP/GnuPG encrypted mail preferred in all private communication.
 Key ID: 0x293C05FD - 997A 4C60 CE41 0149 0DB3  9E96 2F1A D073 293C 05FD

Mime
View raw message