incubator-ooo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Stahl <...@openoffice.org>
Subject Re: Try to build OOo , but meet error......
Date Mon, 11 Jul 2011 12:27:33 GMT
On 09.07.2011 06:19, L'oiseau de mer wrote:
> if without setting CC and CXX, configure will use gcc and appear ld error.
> if CC=cc and CXX=CC , configure will appear :
> checking for cc... /opt/solstudio12.2/bin//cc
> checking the SunStudio C/C++ compiler version... configure: error:
> found version "5.11", use version 5.5, 5.7, 5.8 or 5.9 of the
> SunStudio C/C++ compiler
>
> and i also try to use sunstudio11:but it has other error

AFAIK we used only SunStudio 12.0 release to build OOo; you should have 
the least problems with this version.
SunStudio 12 update releases had some kind of problem with boost or 
something.

> ube: error: Assert has been violated at
> '/set/venus/builds.intel-S2/nightly.Thu/intel-S2/lang/ube/graphs/src/scregion.c
> 305'.
> cc: ube failed for ../../../js/src/jsinterp.c

this looks like a compiler bug...

> and then i enter vcl directory,run gmake -r:

> CC: Warning: Option -xMMD passed to ld, if ld is invoked, ignored otherwise
> CC: Warning: Option -xMF passed to ld, if ld is invoked, ignored otherwise

aha, interesting: this version does not understand the options we use in 
gbuild to write dependency files.

Google finds this, which says that these are only supported since 
SunStudio 12:
http://192.9.162.65/sunstudio/support/Ccompare.html

this means that older versions of SunStudio won't work currently for OOo.



Mime
View raw message