incubator-ooo-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From p..@apache.org
Subject svn commit: r1399479 - /incubator/ooo/trunk/main/configure.in
Date Wed, 17 Oct 2012 23:19:48 GMT
Author: pfg
Date: Wed Oct 17 23:19:48 2012
New Revision: 1399479

URL: http://svn.apache.org/viewvc?rev=1399479&view=rev
Log:
Clean up the python detection for Python 3.

While here request Python be at least version 2.3. While this
version is likely to cause trouble, there is no other option
for older Mac PPC.

The ongoing updates in the python support will require bumping
the minimum to at least Python 2.6 but the recommendation is to
use the internal Python 2.7.x.

Modified:
    incubator/ooo/trunk/main/configure.in

Modified: incubator/ooo/trunk/main/configure.in
URL: http://svn.apache.org/viewvc/incubator/ooo/trunk/main/configure.in?rev=1399479&r1=1399478&r2=1399479&view=diff
==============================================================================
--- incubator/ooo/trunk/main/configure.in (original)
+++ incubator/ooo/trunk/main/configure.in Wed Oct 17 23:19:48 2012
@@ -4091,10 +4091,10 @@ elif test -n "$with_system_python" -o -n
 	test "$with_system_python" != "no"; then
    with_system_python=yes
    AC_MSG_RESULT([external])
-   AM_PATH_PYTHON([2.2])
+   AM_PATH_PYTHON([2.3])
 
-   python_include=`$PYTHON -c "import distutils.sysconfig; print distutils.sysconfig.get_config_var('INCLUDEPY');"`
-   python_version=`$PYTHON -c "import distutils.sysconfig; print distutils.sysconfig.get_config_var('VERSION');"`
+   python_include=`$PYTHON -c "import distutils.sysconfig; print(distutils.sysconfig.get_config_var('INCLUDEPY'));"`
+   python_version=`$PYTHON -c "import distutils.sysconfig; print(distutils.sysconfig.get_config_var('VERSION'));"`
    PYTHON_CFLAGS="-I$python_include"
    PYTHON_LIBS="-lpython$python_version"
 fi



Mime
View raw message