incubator-ooo-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From conflue...@apache.org
Subject [CONF] Apache OpenOffice Community > IP_Clearance Impact
Date Sun, 29 Jan 2012 23:34:00 GMT
Space: Apache OpenOffice Community (https://cwiki.apache.org/confluence/display/OOOUSERS)
Page: IP_Clearance Impact (https://cwiki.apache.org/confluence/display/OOOUSERS/IP_Clearance+Impact)

Change Comment:
---------------------------------------------------------------------
Some rewording.

Edited by Pedro Giffuni:
---------------------------------------------------------------------
h2. IP Clearance: Impact

The following list describes the impact on GUI level of removal and replacement of libraries
as described on the [IP_Clearance|IP_Clearance] page.  Its intended purpose is to keep track
of lost or modified functionality.

Changes that may impact users:
|| Library || What is changing || User Impact ||
| lp_solve | lp_solve was replaced by CoinMP \\
\\
\\
\\ | This functionality is invoked by the user in Calc via   Tools->Solver.  
  It is used for solving linear programming   problems, including integer    programming.\\
 \\
CoinMP comes from the [Coin-OR|http://www.coin-or.org/] open source project, an open source
project that involves operations    research professionals and includes cutting edge algorithms.
\\
\\
 According to one [research paper|http://www.ceem.unsw.edu.au/content/userDocs/stu-ORMMES06_Benchmarking_20060610_FINAL_CEEM.pdf]
CoinMP offers superior performance compared to lp_solve.  So the overall user impact
from this change should be positive. |
| i18nregexp | i18nregexp was replaced by ICU Regular Expressions. | No major impact for users;
regular expressions will work as usual and be much faster. Some deprecated extended syntax
supported in earlier versions may not be available. |
| MySQL Connector/C+\+ | | MySQL connector can only be built when the C+\+ connector is pre-installed
on the system.  It will not be part of the binary release. |
| SVG: librsvg, libcroco, libgsf, gdk-pixbuf, glib, gettext, pango | These libraries are being
removed from the product.\\ | Instead of using an external SVG rendering library, Apache OpenOffice
3.4 will feature native SVG support, giving high quality, scalable, standards-compliant rendering
on screen, print and PDF export.\\ |
| libwpd | The libwpd library is being removed from the product. \\ | The WordPerfect filter
("WordPerfect Document (.wpd)") won't be available anymore. It depended on version 0.8 of
the library anyways so no replacement unless someone creates a filter extension that can be
installed separately. |
| fonts (liberation) | These fonts are being removed from the distribution due to an incompatible
license. \\ |  Metrically equivalent fonts from Google's ChromeOS have been included as replacements:
[Tinos|http://www.google.com/webfonts/specimen/Tinos], [Arimo|http://www.google.com/webfonts/specimen/Arimo]
and [Cousine|http://www.google.com/webfonts/specimen/Cousine]. Moreover, users may independently
install liberation fonts to their system, in accordance with their license.  so there
is no further user impact. |
| libneon | The neon library is being removed from the distribution due to an incompatible
license. \\ | The neon library is used to for all http based communication including WebDAV.
Without a replacement it is for example not possible to insert an image via an http Url. \\
 \\
Work on a replacement ([118569|https://issues.apache.org/ooo/show_bug.cgi?id=118569]) has
started but we will potentially lose WebDAV support at the beginning. |
| berkeleydb | The berkeleydb library is being removed from the distribution due to an incompatible
license. \\ | The berkeleydb is used for managing extentions and was used for indexing help
content. \\
 \\
Managing a handful of extensions using a database was overkill anyways and that is being rectified
([118569|https://issues.apache.org/ooo/show_bug.cgi?id=118662]). The impact is that extensions
installed for older versions of OpenOffice have to be re-installed. |
| core, flute, flow-engine, libbase, libfonts, libformula, liblayout, libloader, librepository,
libserializer, libxml | Libraries used by the Report Builder extension are being removed due
to an incompatible license. | Report Builder extension will not be available unless someone
works on it as an external extension.|
| ooo_crystal_images-1.tar.gz \\ ooo_oxygen_images-2009-06-17 | Crystal and Oxygen icons removed.
| These were used by default in KDE and KDE4 only. The user can still choose other icon sets
like galaxy or tango. |

Changes with impact for developers but not for users:
|| Library || What is changing || Developer Impact ||
| glibc | glibc is being removed from the product \\ | No impact for user. If needed, developers
will have to bring their own portable getopt() function to parse command lines (APR has one).
|
| dmake | dmake source code has been removed. | The configure script has to be told where
to find the dmake source (URL, path). |
| epm | epm source code has been removed. | The configure script has to be told where to find
the epm source (URL, path) or to build just the archives. |
| cppunit | cppunit source code has been removed. | cppunit tests have never been part of
binary packages, therefore there is no impact for users.  Developers have to install it manually
in order to use it during development. |

Changes without any impact:
|| Library || What is changing || Remarks ||
| dictionaries | The dictionaries have been removed from SVN. | Precompiled dictionary extensions
can still be installed from the extension repository.  When we figure out how to bundle them
with the install set, there should be no visible impact for the user. |
| cups | The cups source code has been removed. | It was not used (anymore), so no impact
at all. |
| rhino | The rhino library will be updated to current version 1.7R3 which eliminates the
use of the conflicting swingEx library. | Newer library should improve usability. |
| xpdf | The xpdf source code was removed. | No impact for final users, since this only affected
an extension. PDF import can only be built when the poppler library is pre-installed on the
system.  It will not be part of the binary release. |


Change your notification preferences: https://cwiki.apache.org/confluence/users/viewnotifications.action
   

Mime
View raw message