incubator-olio-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amanda Waite <amandarwa...@gmail.com>
Subject Re: Exception: In event detail and select event is null
Date Thu, 23 Dec 2010 09:02:18 GMT
It's likely to be a Rails routing issue, I had a few random occurrences of
this but it always went away when I investigated. Take a look at
http://www.tutorialspoint.com/ruby-on-rails-2.1/rails-routes.htm for an
insight into how routing works. You should be able to figure out whey the
redirect is happening on your setup.

Mandy

On Thu, Dec 23, 2010 at 4:11 AM, Sahan Gamage <sahans@gmail.com> wrote:

> Thanks for the quick reply.
> Here are some details of the system:
> OS: Ubuntu 9.04
> Ruby : 1.8.7
> Rails : 2.3.5
> proxy : nginx 0.6.35
>
> I did some more digging into the problem and I logged the entire html
> page when the exception occurs (doEventDetail) in UIDriver.java. It
> seems like server sends a redirection message (<html><body>You are
> being <a href="http://10.0.100.176/home">redirected</a>.</body></html>)
> and that's why it fails to scrape an event from the html.
>
> I am looking into this one
> If you have seen this before and know a quick fix pls let me know.
>
> Thanks a lot
> -sahan
>
> On Wed, Dec 22, 2010 at 3:52 AM, Amanda Waite <amandarwaite@gmail.com>
> wrote:
> > It means that the driver was unable to scrape an Event ID from the
> HomePage
> > which itself suggests that the HomePage wasn't rendered correctly. What
> > version of Ruby? What version of Rails? What OS? Is there anything in the
> > logs? If not and you are running in production you might want to run in
> > development mode and run a smaill test and observe what happens when
> > EventDetail fails.
> >
> > We still only support Ruby 1.8.7 and Rails 2.3.5
> >
> > Thanks
> >
> > Mandy
> >
> > On Wed, Dec 22, 2010 at 4:19 AM, Sahan Gamage <sahans@gmail.com> wrote:
> >>
> >> Hi all,
> >>
> >> I configured faban/olio to run a performance test with Ruby version of
> >> Olio.
> >>
> >> When I run the performance test I get this warning (and the
> >> IOException) in the faban Run Log:
> >>
> >> UIDriverAgent[0].1.doEventDetail: In event detail and select event is
> null
> >>
> >> Trace:
> >>
> >> org.apache.olio.workload.driver.UIDriver        doEventDetail   656
> >> sun.reflect.GeneratedMethodAccessor6    invoke
> >> sun.reflect.DelegatingMethodAccessorImpl        invoke  25
> >> java.lang.reflect.Method        invoke  597
> >> com.sun.faban.driver.engine.TimeThread  doRun   169
> >> com.sun.faban.driver.engine.AgentThread run     202
> >>
> >> Once the test is completed I see that lot of (39 out of 91)
> >> "EventDetail" operations are failed  (this is a small test run - so
> >> the numbers are small)
> >>
> >> What might be the cause of this problem ?
> >> How does this affect the results, in the sense of throughput and
> response
> >> time ?
> >>
> >> Thanks in advance
> >> -sahan
> >
> >
>

Mime
View raw message