incubator-olio-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shanti Subramanyam <shanti.subraman...@gmail.com>
Subject Re: exceptions/warnings during benchmark run
Date Sat, 31 Jul 2010 05:56:25 GMT
On Fri, Jul 30, 2010 at 2:21 AM, Alexander Stage <stage@in.tum.de> wrote:

> Dear Sankalp,
>
> thanks for your quick reply. Restarting glassfish solved problem 1 (I guess
> it is a caching issue in the persistence layer, even though I set the
> -DcacheOlio=false flag).
>
>
The JPA layer will still cache data. Every time you reload the database, it
is important to restart the appserver as well.
This is true for all the 3 Olio apps - not just Java.


> the solution to problem 2 troubles me a little bit, as I am planning to
> generate variable load profiles. However, your solution to problem 2 solved
> to the issue. Is the second issue a java implementation specific one (do the
> php or ruby implementations do not suffer from this "limitation" ?)
>
>
I thought the Java version did not require the db to be loaded to the same
#users as the load driver. If you can check what key value is being used for
the new users being added, this can perhaps be worked around by picking the
1st key to be beyond the max user_id in the database rather than #users
being run.

I believe someone else on this list tried a variable load some time.

I'll give the variable load profiles a try later on. Again, thanks for your
> help.
>
> Cheers,
>
> Alex
>
> Shanti

>
> Sankalp Gera wrote:
>
>> I did face similar problems long time back. I guess you are not
>> restarting your webserver which is possibly causing  the first issue
>> whereas to resolve the second issue I guess you need to maintain the
>> number of concurrent users same as the number for which DB is loaded.
>> I am not sure of the second solution but the first one should work.
>>
>> Sankalp
>>
>> On Fri, Jul 30, 2010 at 7:32 AM, Shanti Subramanyam
>> <shanti.subramanyam@gmail.com> wrote:
>>
>>> I have certainly seen the errors you refer to but my memory is bad and I
>>> don't recall the exact solution.
>>>
>>> One issue that everyone runs into is the fact that the filestore may not
>>> be
>>> writable by the server process. If you run faban as the same user as
>>> glassfish, this should work. If not, the image file creates will fail
>>> causing the 2. error below. That error should usually result in a stack
>>> trace in the server log. Are you sure there is nothing in the log ?
>>> I suggest delete the filestore entirely and re-populating it if you can't
>>> make progress.
>>>
>>> For 1., if you can't manually login, it seems like either the database is
>>> messed up or the driver is not in synch with it. Can you please do a SQL
>>> query on the database and see what username/passwords you see (send a few
>>> in
>>> email - say the first 10 rows).
>>>
>>> Shanti
>>>
>>>
>>> On Thu, Jul 29, 2010 at 6:41 AM, Alexander Stage <stage@in.tum.de>
>>> wrote:
>>>
>>>> Dear all,
>>>>
>>>> I am running the java olio benchmark on glassfishv3 (3.0.1), jdk 1.6.21,
>>>> (sandboxed) mysql 5.5.5 on centos 5.5. The database as well as the
>>>> filestore
>>>> have been populated  for 1000 users. The database gets populated before
>>>> each
>>>> run. The webapp runs fine when testing it manually as suggested in the
>>>> user
>>>> guide.
>>>>
>>>> The following problems occur for runs with any amount of users (25 -
>>>> 1000):
>>>>
>>>> 1. During a benchmark run I am getting a lot of
>>>> "java.lang.RuntimeException: Found login prompt at index 748, Login as
>>>> X, Y
>>>> failed." warning messages in the run log. These execptions do not seem
>>>> to
>>>> have a counterpart in the server logs. And indeed, when try to log into
>>>> the
>>>> system as user X using passwd Y, the login does not succeed. Actually
>>>> only a
>>>> very few users (the first five created in the db) are able to login. For
>>>> a
>>>> short run with 25 users (360 seconds steady state) this  behavior
>>>> results in
>>>> 1 successful logins and 178 failed ones.
>>>>
>>>> 2. Additionally I can see quite a lot of "Duplicate entry 'l88i778w' for
>>>> key 'PERSON_USER_IDX'" exceptions in the server log that (I guess) cause
>>>> warnings in the run log as follows: "java.io.IOException: Multipart Post
>>>> did
>>>> not work, returned status code: 500".
>>>>
>>>> Are these known problems ? Any help would be highly appreciated.
>>>>
>>>> Cheers,
>>>>
>>>> Alex
>>>>
>>>
>>>
>>
>

Mime
View raw message