incubator-olio-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amanda Waite <amandarwa...@googlemail.com>
Subject Re: A few problems with Olio 0.2
Date Mon, 07 Jun 2010 15:46:54 GMT
Sorry, meant to say "are you able to" or "can you" in the second sentence.

Amanda

On Mon, Jun 7, 2010 at 4:45 PM, Amanda Waite <amandarwaite@googlemail.com>wrote:

> Thanks, for the investigations! Are you raise a Jira ticket for this (
> https://issues.apache.org/jira/login.jsp) if you have a patch then you can
> attach it to the ticket. I'll make sure it gets integrated. If you can't
> provide a patch that's fine, I'll get to it as soon as I can.
>
> Thanks
>
> Amanda
>
>
>
>
> On Mon, Jun 7, 2010 at 4:38 PM, <xavier.dutreilh@orange-ftgroup.com>wrote:
>
>>  After some investigations, I found out that links on the event page are
>> all wrong while the ones on the home page are not. So, it affects not
>> only the comment feature but also action buttons as 'Edit' and 'Delete'.
>>
>> In fact, I noticed that links contains references to an Event object and
>> not to the actual event id. To be more concrete, instead of this:
>> http://10.193.128.108:3000/events/%23%3CEvent:0xb66c6680%3E/edit
>> it should be this: http://10.193.128.108:3000/events/1/edit
>> In the stable release (0.2), I saw that you're using @event (or event)
>> when building links. To fix this issue, it should be @event.id or
>> event.id (depending of the context).
>>
>> Hope it helps. :)
>>
>>
>> Regards,
>>
>> Xavier Dutreilh
>> FT/RD/RD/MAPS/MEP/LOV
>> Thésard
>> tél. 01 45 29 48 19
>> xavier.dutreilh@orange-ftgroup.com
>>
>>
>> On Mon, 2010-06-07 at 15:42 +0200, xavier.dutreilh@orange-ftgroup.com
>>
>> wrote:
>> > Thank you for your answer, Amanda.
>> >
>> > About the second issue, I'll take a look at the code and see what
>> > might
>> > go wrong... since logs are clean (no errors reported).
>> >
>> > Best regards,
>> >
>> >
>> > Xavier Dutreilh
>> > FT/RD/RD/MAPS/MEP/LOV
>> > Thésard
>> > tél. 01 45 29 48 19
>> > xavier.dutreilh@orange-ftgroup.com
>> >
>> >
>> > On Mon, 2010-06-07 at 13:59 +0100, Amanda Waite wrote:
>> > > Hi Xavier,
>> > >
>> > > I had noticed the first issue, but haven't yet logged a ticket for
>> > it,
>> > > It may be fixed in the trunk, but I need to check. I've not seen the
>> > > second issue, but we focus more on the test operations passing and
>> > > comments on events isn't a test operation. If I can recreate it,
>> > I'll
>> > > log a ticket and fix it in the trunk. Feel free to take it on
>> > yourself
>> > > in the meantime. I'm just in the process of rebuilding an Olio Rails
>> > > rig.
>> > >
>> > > Amanda
>> > >
>> > > On Mon, Jun 7, 2010 at 12:37 PM,
>> > <xavier.dutreilh@orange-ftgroup.com>
>> > > wrote:
>> > >         Hi,
>> > >
>> > >         I tried to deploy Olio 0.2 on a bunch of KVM hosts. I used
>> > >         this simple
>> > >         deployment scheme:
>> > >         - VM#1: Database Server (MySQL)
>> > >         - VM#2 & 3: Apache Olio (run through the Ruby Thin server)
+
>> > >         Geocoder
>> > >         (run through Tomcat)
>> > >         - VM#4: Load balancer (nginx)
>> > >
>> > >         At this point, everything seems to work well. I can sign up,
>> > >         create
>> > >         events and even make friendships.
>> > >         But I noticed a few bad things:
>> > >         - The event page displays an ASF licence above the Yahoo!
>> > map
>> > >         (see
>> > >         http://midgar.fr/issues/olio/pic1.png ). It seems that HTML
>> > >         comment tags
>> > >         are missing: <!-- and -->
>> > >         - When I post a comment to an event, it fails. After
>> > >         submitting the
>> > >         form, on the next page, it says "Event does not exist." (see
>> > >         http://midgar.fr/issues/olio/pic2.png ).
>> > >
>> > >         Are these two issues known problems? If so, does the current
>> > >         SVN trunk
>> > >         version fix (at least) the second issue? Or should I start
>> > >         thinking
>> > >         about an error in my Olio deployment?
>> > >
>> > >         Thanks for any input.
>> > >
>> > >         Best regards,
>> > >
>> > >
>> > >         Xavier Dutreilh
>> > >         FT/RD/RD/MAPS/MEP/LOV
>> > >         Thésard
>> > >         tél. 01 45 29 48 19
>> > >         xavier.dutreilh@orange-ftgroup.com
>> > >
>> > >
>> > >
>> > >
>> > >
>> > >
>> >
>> >
>>
>
>

Mime
View raw message