incubator-olio-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Caspole <eric.casp...@amd.com>
Subject Re: undefined function get() - what is the problem?
Date Tue, 09 Feb 2010 18:26:32 GMT
If you are building PHP for yourself, could you scrape your configure  
line and send it to me? I am running on CentOS and I would like to be  
able to build it all but I am not opposed to sucking in something by  
yum if it saves me spinning wheels. I am using PHP 5.3.1.

I am narrowing in on most of these problems, thanks for your help.
Eric


On Feb 9, 2010, at 10:18 AM, Shanti Subramanyam wrote:

> If you look at the code and line# it is complaining about, you will  
> see that this is a database call. We use pdo_mysql extension for  
> connecting to mysql. I don't recall if PHP has this by default (the  
> easiest way to check is to execute a script that has  <?php phpinfo 
> (); ?> in it.
>
> Shanti
>
> On Mon, Feb 8, 2010 at 2:59 PM, Eric Caspole <eric.caspole@amd.com>  
> wrote:
> Hello Olio experts,
>
> I am setting up a PHP test bed from scratch using the instructions  
> in the repository at olio/docs/php_setup.html, using the 0.2 tag  
> code. I am pretty new to PHP but I am generally familiar with  
> setting up and installing several different php extensions.
>
> My setup is basically working, seeing the maps and events and all  
> that, except for trouble getting the user picture to upload when I  
> click update in the user editor page. I assume I have some mistake  
> in my PHP configuration. After hitting update, the addPersonResult  
> page comes back blank with this error in the apache error log:
>
>
> [Mon Feb 08 13:33:54 2010] [error] [client 163.181.250.55] PHP  
> Fatal error:  Call to undefined function get() in /usr/local/ 
> apache2/htdocs/oliophp/public_html/addPersonResult.php on line 109,  
> referer: http://10.236.44.126/addPerson.php?username=ecaspole
>
>
> I have configured my PHP as
>
>  ./configure --with-pdo-mysql --with-curl=/home/ecaspole/views/php/ 
> php-5.3.1/ext/curl  --with-apxs2=/usr/local/apache2/bin/apxs   -- 
> with-gd --enable-memcache --with-jpeg-dir=/usr/lib
>
> Is there anything missing or wrong with this? What else could it be?
> Thanks for any advice,
> Eric
>
>
>



Mime
View raw message