incubator-olio-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harold Lim <rold...@yahoo.com>
Subject Re: Olio + Faban
Date Fri, 14 Aug 2009 21:28:44 GMT
Hi Akara,

What exactly is the driver? I'm not sure if I have a "driver".

This is how I set up my machines:

I have 1 machine with faban, which I run faban/master/bin/startup.sh

In my other machine with glassfish, I run faban/bin/agent

In my DB, I run faban/bin/agent.


Thanks,
Harold


--- On Fri, 8/14/09, Akara Sucharitakul <Akara.Sucharitakul@Sun.COM> wrote:

> From: Akara Sucharitakul <Akara.Sucharitakul@Sun.COM>
> Subject: Re: Olio + Faban
> To: "Harold Lim" <rold_50@yahoo.com>
> Cc: olio-user@incubator.apache.org
> Date: Friday, August 14, 2009, 5:19 PM
> Harold Lim wrote:
> > Hi Akara,
> > 
> > It's just that I've modified the Java implementation
> of olio to run with Glassfish, postgresql and HDFS. I'm not
> really interested in the performance of the database but
> rather the filesystem. At the very least, I'm just
> interested in the performance at the front end (response
> time of user browsing the web app, which is indirectly
> related to the performance of the file system). Ultimately,
> I'm interested in the throughput of each storage nodes of my
> HDFS.
> > 
> > Also, when I run faban, I get exception reading
> /my.cnf, which is true since postgresql doesn't have
> my.cnf.
> 
> Just ignore it. We would have to edit the Olio benchmark
> class and rebuild the driver to get rid of it. Future
> versions will allow you to use different services
> transparently, avoiding the message altogether.
> > 
> > 
> > One question though: In the olio driver tab, is the
> host = the IP of the master? or the IP of the machine
> containing glassfish?
> > My current set up is like this: 1 machine for master,
> 1 machine for postgresql, 1 machine for glassfish.
> 
> The host in this tab refers to the driver systems. You can
> use ip addresses or host names, separated by space.
> 
> > 
> > 
> > I set up the host to be the IP of glassfish. When I
> run the benchmark, I get failed:
> > 
> > HomePage    0   
> 0    0%   
> 26.15%    FAILED
> > Login    0   
> 0    0%   
> 10.22%    FAILED
> > TagSearch    0   
> 0    0%   
> 33.45%    FAILED
> > EventDetail    0   
> 0    0%   
> 24.68%    FAILED
> > PersonDetail    0   
> 0    0%   
> 2.61%    FAILED
> > AddPerson    0   
> 0    0%   
> .84%    PASSED
> > AddEvent    0   
> 0    0%   
> 2.04%    FAILED
> 
> Simply, none of the operations went through.
> 
> > I'm pretty sure that olio is working for me because I
> can manually go to the olio web app from my browser and
> browse/create user, events, etc.
> 
> Well, we need to know what's not working, then. Check your
> run log.
> 
> -Akara
> > 
> > 
> > 
> > 
> > 
> > --- On Fri, 8/14/09, Akara Sucharitakul <Akara.Sucharitakul@Sun.COM>
> wrote:
> > 
> >> From: Akara Sucharitakul <Akara.Sucharitakul@Sun.COM>
> >> Subject: Re: Olio + Faban
> >> To: olio-user@incubator.apache.org
> >> Date: Friday, August 14, 2009, 4:51 PM
> >> I've to check whether it is exposed,
> >> but you can certainly edit the config file and
> mark the host enabled=false. However, I
> >> don't suggest that. Olio depends on the agent to
> reload the DB, etc.
> >> 
> >> Can you please let me know why you don't want to
> run the
> >> agent on the DB server?
> >> 
> >> As for the data store, I don't think the
> distributed stores
> >> are well integrated. Why don't you get successful
> runs with the
> >> local store first and we can then add support for
> those.
> >> 
> >> -Akara
> >> 
> >> Harold Lim wrote:
> >>> Thanks.
> >>> I have a few more questions:
> >>> 
> >>> Is there a way to only test the webapp? (i.e.,
> I don't
> >> want to run faban agent on my DB server). When I
> put blank
> >> for host name of db server when setting up my run
> in faban,
> >> I get like a null pointer exception.
> >>> Also, in the data storage server section of
> faban, how
> >> do I set it up if I am not using local store? I
> have set up
> >> a distributed storage to host my file store (e.g.,
> hdfs,
> >> mogilefs).
> >>> 
> >>> 
> >>> Thanks,
> >>> Harold
> >>> 
> >>> 
> >>> --- On Fri, 8/14/09, Akara Sucharitakul <Akara.Sucharitakul@Sun.COM>
> >> wrote:
> >>>> From: Akara Sucharitakul <Akara.Sucharitakul@Sun.COM>
> >>>> Subject: Re: Olio + Faban
> >>>> To: olio-user@incubator.apache.org
> >>>> Date: Friday, August 14, 2009, 4:10 PM
> >>>> The file faban.xml did not get
> >>>> generated at deployment for some reason.
> Just
> >> remove the
> >>>> olio deploy directory under
> $FABAN/benchmarks and
> >> restart
> >>>> the Faban harness. As Faban unjars the
> Olio
> >> benchmark jar it
> >>>> should generate the file. Thanks.
> >>>> 
> >>>> -Akara
> >>>> 
> >>>> Harold Lim wrote:
> >>>>> When I try to schedule a run in Faban:
> I get
> >> the
> >>>> following error in my log:
> >>>>> record>
> >>>>>    
> >> <date>2009-08-14T15:05:34</date>
> >>>>>    
> >> <millis>1250276734815</millis>
> >>>>>    
> >> <sequence>65</sequence>
> >>>>>    
> >>
> <logger>com.sun.faban.harness.common.BenchmarkDescription</logger>
> >>>>>    
> >> <level>WARNING</level>
> >>>>>    
> >>
> <class>com.sun.faban.harness.common.BenchmarkDescription</class>
> >>>>>    
> >> <method>readDescription</method>
> >>>>> 
>    <thread>11</thread>
> >>>>> 
>    <message>Error reading
> >>>> benchmark descriptor for
> >>>> 
> >>
> /home/harold/Desktop/faban/benchmarks/olio</message>
> >>>>> 
>    <exception>
> >>>>>   
> >>>> 
>    <message>java.io.IOException:
> >>>> Element &lt;metric&gt; empty or
> missing
> >> in
> >>
> /home/harold/Desktop/faban/benchmarks/olio/META-INF/benchmark.xml</message>
> >>>>>   
>    <frame>
> >>>>>     
> >>>>    
> >>
> <class>com.sun.faban.harness.common.BenchmarkDescription</class>
> >>>>>     
> >>>>    
> >> <method>readDescription</method>
> >>>>>     
> >>>> 
>    <line>276</line>
> >>>>>   
>    </frame>
> >>>>>   
>    <frame>
> >>>>>     
> >>>>    
> >>
> <class>com.sun.faban.harness.common.BenchmarkDescription</class>
> >>>>>     
> >>>>    
> >> <method>generateMaps</method>
> >>>>>     
> >>>> 
>    <line>181</line>
> >>>>>   
>    </frame>
> >>>>>   
>    <frame>
> >>>>>     
> >>>>    
> >>
> <class>com.sun.faban.harness.common.BenchmarkDescription</class>
> >>>>>     
> >>>>    
> >> <method>checkMaps</method>
> >>>>>     
> >>>> 
>    <line>165</line>
> >>>>>   
>    </frame>
> >>>>>   
>    <frame>
> >>>>>     
> >>>>    
> >>
> <class>com.sun.faban.harness.common.BenchmarkDescription</class>
> >>>>>     
> >>>>    
> >> <method>getDescription</method>
> >>>>>     
> >>>> 
>    <line>126</line>
> >>>>>   
>    </frame>
> >>>>>   
>    <frame>
> >>>>>     
> >>>>    
> >>
> <class>com.sun.faban.harness.engine.RunDaemon</class>
> >>>>>     
> >>>>    
> >> <method>fetchNextRun</method>
> >>>>>     
> >>>> 
>    <line>160</line>
> >>>>>   
>    </frame>
> >>>>>   
>    <frame>
> >>>>>     
> >>>>    
> >>
> <class>com.sun.faban.harness.engine.RunDaemon</class>
> >>>>>     
> >>>> 
>    <method>run</method>
> >>>>>     
> >>>> 
>    <line>272</line>
> >>>>>   
>    </frame>
> >>>>> 
> >>>>> 
> >>>>> Any ideas what's causing that?
> >>>>> 
> >>>>> 
> >>>>> Thanks,
> >>>>> Harold
> >>>>> 
> >>>>> 
> >>>>>     
>    
> >>> 
> >>> 
> >> 
> > 
> > 
> > 
> 
> 


      

Mime
View raw message