incubator-odf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Weir <robw...@apache.org>
Subject Re: Update dependencies?
Date Wed, 22 Jan 2014 17:50:04 GMT
On Wed, Jan 22, 2014 at 12:40 PM, Florian Hopf <fhopf@apache.org> wrote:
> On 21.01.2014 20:17, Rob Weir wrote:
>>
>> I went through our POM's to see if we had any dependencies that were
>> worth updating.  Here's a quick summary of what I found.
>>
>
> I hope I don't interfere with any work you already did but I just moved all
> the versions to a dependencyManagement section in the root pom. This way it
> should be far more easy do update versions in the future. Everything builds
> and tests fine on my machine.
>

No problem.  This is fine.

I noticed we have some dependencies that list no version.  What does
Maven do in that case?  Use the most-recent version?  Use whatever
version is already cached?   Should we be explicit everywhere with a
version?

-Rob


> We now have only one dependency in different versions: the schema-generator
> needs a different version of msv-core.
>
> I will now continue to analyze the poms to declare the dependencies we use
> correctly.
>
>
> --
> Florian Hopf
> Freelance Software Developer
>
> http://blog.florian-hopf.de

Mime
View raw message