incubator-odf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian C <...@amham.net>
Subject Re: Update dependencies?
Date Wed, 22 Jan 2014 01:51:20 GMT
I think keeping things up to date is a good idea. Which Java version are we
aiming it at?

I run on Fedora and Windows occasionally, if I can make the time I can test
there to see if that would be useful?


On Wed, Jan 22, 2014 at 3:17 AM, Rob Weir <robweir@apache.org> wrote:

> I went through our POM's to see if we had any dependencies that were
> worth updating.  Here's a quick summary of what I found.
>
> The following are up to date:
>
> ant-nodeps 1.8.1
> java-rdfa 0.4.2
> commons-validator 1.4.0
>
> The following have newer versions available, with the newer version in
> parentheses:
>
> xercesImpl 2.9.1 (2.11)
> junit 4.8.1 (4.11)
> jena-arq 2.9.4 (2.11.0)
> jena-core 2.7.4 (2.11.0)
> maven-compiler-plugin 2.3.2 (3.1)
> maven-javadoc-plugin 2.7 (2.9.1)
> maven-source-plugin 2.1.2 (2.2.1)
> maven-assembly-plugin ? (2.4)
> apache-rat-plugin ? (0.1.0)
> maven-gpg-plugin 1.1 (1.4)
> maven-release-plugin 2.0-beta-9 (2.4.2)
>
> It probably is safe to update the build-time tools (junit, rat and the
> maven plugins), yes?
>
> What about the run time dependencies?
>
> -Rob
>



-- 
Cheers,

Ian C

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message