incubator-odf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Weir <robw...@apache.org>
Subject Re: JDK 7 Results (was RE: [VOTE] Release Apache ODF Toolkit 0.5-incubating(RC7))
Date Wed, 04 Jan 2012 02:39:41 GMT
On Tue, Jan 3, 2012 at 7:27 PM, Dennis E. Hamilton
<dennis.hamilton@acm.org> wrote:
> The tools.jar is in the usual JDK location and the packages are there.
>
> There is a way to run Maven where it shows the commands it executes and I may do that
to see what the compile command looks like.  Since Maven is synthesizing class-path parameters,
it would be interesting to see what the compile command is and whether there is a command-line
change in Java 7.
>
> I'm out of time on this for now, but I will take another crack at it eventually.
>

I think I got it.  In taglets/pom.xml, look for tools.jar.  The vendor
changed in the Java 7 version from "Sun Microsystems Inc." to "Oracle
Corporation".  That vendor name switch causes Maven not to see that
dependency.  Ouch.

I changed the vendor name and it is not building under Java 7, or at
least it has got past that error.  We'll see in another 20 minutes or
so if it completes.

I wonder if we can simply list the JAR twice, once with each vendor?
Maven seems to ignore the one it can't find.

I wonder how this worked at all with OpenJDK?  Do they just list
themselves as coming from Sun for compatibility?


-Rob

>  - Dennis
>
> -----Original Message-----
> From: Rob Weir [mailto:robweir@apache.org]
> Sent: Tuesday, January 03, 2012 13:17
> To: odf-dev@incubator.apache.org
> Subject: Re: JDK 7 Results (was RE: [VOTE] Release Apache ODF Toolkit 0.5-incubating(RC7))
>
> On Mon, Jan 2, 2012 at 1:35 AM, Dennis E. Hamilton
> <dennis.hamilton@acm.org> wrote:
>> Just for fun, I also attempted to build (rc7) with JDK 7u2, since JDK 6u30
>> seemed to work so well.
>>
>> No joy.  The Maven clean install failed with compiler errors in the very first
>> compiles.
>>
>>  - Dennis
>>
>> SOME DETAILS
>>
>> I don't think this is an ODF Toolkit problem.  It appears to be somewhere
>> between Maven and JDK 7.  The basic situation is that com.sun.javadoc and
>> other packages in the %JAVA_HOME%\lib\tools.jar are not found.  I tried
>> several variations (but I did not restrict Maven to not use any parallel
>> builds).
>>
>
> Does Java 7 give you a tools.jar at all?  If so, what happens if you
> just add it to the classpath?
>
> -Rob
>
> [ ... ]
>

Mime
View raw message