incubator-odf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Devin Han <devin...@apache.org>
Subject Re: Standalone "mvn clean" fails
Date Fri, 23 Dec 2011 06:05:47 GMT
Thank you very much for the detail information.
This issue is cuased by the conf in validator pom.xml:

                    <execution>
                        <id>clean schema files</id>
                        <phase>clean</phase>
                        <configuration>
                            <tasks>
                                <echo message="remove schema files" />
                                <delete>
                                     <fileset
dir="src/main/resources/schema/" excludes="odf*.properties"
defaultexcludes="false"/>
                                </delete>
                            </tasks>
                        </configuration>
                        <goals>
                            <goal>run</goal>
                        </goals>
                    </execution>

I add it for clean the download shcemas, but it caused building failed....
Fortunately, I found a better way to fix it.

2011/12/22 Yegor Kozlov <yegor.kozlov@dinom.ru>

> It turns out that standalone "mvn clean" fails if "mvn install" wasn't
> called before.
>
> Checkout trunk on a machine with empty local repo. Try "mvn clean" and
> it will fails.
>
> Now run "mvn install". The ODFToolkit jars are now in the local repo.
> Try "mvn clean" and it works.
>
> Delete the generated artifacts from local repo. "mvn clean" doesn't
> work any longer.
>
>
> Yegor
>
> On Thu, Dec 22, 2011 at 12:58 PM, Devin Han <devinhan@apache.org> wrote:
> > 2011/12/22 Yegor Kozlov <yegor.kozlov@dinom.ru>
> >
> >> I can reproduce it with Sun JDK 1.6.26 and Maven 3.0.3 on Win7 and
> Linux.
> >>
> >> My use case is to make a change, run "mvn test" and then check status
> >> with "svn status".
> >> Since the Validator module downloads .rng schemas from internet I see
> >> many not versioned files and this is annoying.
> >>
> >
> > I use Oracle JDK 1.6.0_29, still can reproduce it...
> >
> > I am preparing RC6 and want to know whether this issue is a blocker for
> the
> > first release?
> >
> >
>
> I'd rather not release with failing "mvn clean".
> Do you have anything special in Maven settings ? The behavior was the
> same on both WIn7 and Ubuntu:
>
> - checkout trunk
> - mvn install -Ppedantic
>
> Do you have
>
> Yegor
>



-- 
-Devin

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message