incubator-odf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver Rau <ol...@apache.org>
Subject Re: My testing notes on RC2
Date Tue, 06 Dec 2011 21:51:38 GMT
Hi Rob,

after your comments about not being able to run all the tests
successful I got the RC2 as well:

svn co http://svn.apache.org/repos/asf/incubator/odf/tags/0.5-incubating-rc2/ .

and then ran mvn clean install on it.

The build was completed successful on my machine, so I'm not able to
digg into the issue you described.

This is my config:

Mac OS X 10.7.2
java version "1.6.0_29"Java(TM) SE Runtime Environment (build
1.6.0_29-b11-402-11M3527)Java HotSpot(TM) 64-Bit Server VM (build
20.4-b02-402, mixed mode)
Locale is set to english.

I didn't test the ZIP build as the file is rather large and I have a
low bandwidth connection here. Might be able to take a look tomorrow.

Regarding the readme, I agree with you, it is really helpful now. The
other comment you made (how to build) would fit in there nicely as
well, but I don't think we need that for this release.


Regards


Oliver

On Tue, Dec 6, 2011 at 9:59 PM, Rob Weir <robweir@apache.org> wrote:
> I tested on two machines:
>
> 1) Ubuntu 11 running OpenJDK Runtime Environment (IcedTea6 1.11pre)
> (6b23~pre11-0ubuntu1.11.10) and Maven 2.2.1 (rdebian-6)
>
> 2) Windows XP running Java(TM) SE Runtime Environment (build
> 1.6.0_29-b11) and Maven 3.0.3
>
> For each environment I downloaded the "0.5-incubating-rc2" tag and
> tried a complete build: via "mvn clean package" from the root.  I also
> download the RC2 source ZIP file and did the same.
>
> This is what I'm seeing:
>
> On Linux building from tag, it ends with a unit test failure in the Simple API:
>
> Here is the stack trace:
>
> -------------------------------------------------------------------------------
> Test set: org.odftoolkit.simple.meta.OfficeMetaTest
> -------------------------------------------------------------------------------
> Tests run: 29, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 0.682
> sec <<< FAILURE!
> testGetLanguage(org.odftoolkit.simple.meta.OfficeMetaTest)  Time
> elapsed: 0.021 sec  <<< FAILURE!
> junit.framework.ComparisonFailure: null expected:<[rob]> but was:<[en]>
>        at junit.framework.Assert.assertEquals(Assert.java:81)
>        at junit.framework.Assert.assertEquals(Assert.java:87)
>        at org.odftoolkit.simple.meta.OfficeMetaTest.testGetLanguage(OfficeMetaTest.java:203)
>
>
> This is a functional that gave us trouble in RC1 as well.  IMHO, this
> is not a critical function, so maybe we can disable that test and
> document the problem in the release notes as  a "known issue", with a
> link to a JIRA issue.
>
> If I disable that test case then the build completes successfully and
> I see all of the generated JAR's.
>
> This was running the clean and install targets.  We should probably
> document what is needed for generate the release ZIP files.  This
> probably doesn't need to me in the release itself.  But it would be
> great if you could put together some instructions on the wiki for how
> to make a release, based on what you did here.
>
> On the Windows build I end on the ODFDOM test with this error:
>
> Running org.odftoolkit.odfdom.doc.table.TableCellTest
> org.apache.maven.surefire.booter.SurefireExecutionException: Java heap
> space; nested exception is java.lang.OutOfMemoryError: Java heap space
> java.lang.OutOfMemoryError: Java heap space
>
> I have a 512MB heap, so it is odd to fail in a test case.  I repeated
> with MAVEN-OPTS="-Xmx1025m".  I get the same error.  I tried debugging
> it.  It looks like I'm getting the error in testSetGetFormat(), in the
> 2nd try {} block, when calling
> OdfSpreadsheetDocument.newSpreadsheetDocument().
>
> I'm seeing weird things going on.  It might be due to some recursion
> issues, or some form of interference with the setUp() function. If you
> look at the setUp() function you see it is also calling static
> functions in OdfSpreadsheetDocument.  And I see setUp called twice
> (but not return) before the call to newSpreadsheetDocument() gives the
> memory exception.  Something weird.  But if it is passing for you and
> others, then it could be an issue with by JVM.  But that test function
> is so long and complex that I don't know.  I think the test code
> should be written to be very simple, so we can be sure it is not a
> source of bugs ;-)
>
> The above tests were done on the RC2 tagged files in SVN.  I also
> repeated the tests with the odftoolkit-0.5-incubating-rc2-src.zip.
>
> When I do this, nothing is built.  Maven returns after 7 seconds.  No
> errors.  I see this:
>
> [INFO] Scanning for projects...
> [INFO] ------------------------------------------------------------------------
> [INFO] Building Apache ODF Toolkit
> [INFO]    task-segment: [clean, install]
> [INFO] ------------------------------------------------------------------------
> [INFO] [clean:clean {execution: default-clean}]
> [INFO] [remote-resources:process {execution: default}]
> [INFO] [site:attach-descriptor {execution: default-attach-descriptor}]
> [INFO] [install:install {execution: default-install}]
> [INFO] Installing /home/rob/odftoolkit-0.5-incubating-rc2/pom.xml to
> /home/rob/.m2/repository/org/apache/odftoolkit/odftoolkit/0.5-incubating-rc2/odftoolkit-0.5-incubating-rc2.pom
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD SUCCESSFUL
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 7 seconds
> [INFO] Finished at: Tue Dec 06 15:04:44 EST 2011
> [INFO] Final Memory: 25M/168M
> [INFO] ------------------------------------------------------------------------
>
> If instead of build from the package root I go to each component and
> "mvn clean install" from the subdir, then it works, except for the
> testGetLanguage() test case mentioned earlier.  If I disable that test
> case then everything else builds OK.
>
> I also took a quick look at the binary package,  I noticed it was
> larger than the source release, which I thought was odd.  It looks
> like you are including the source ZIP file inside of the binary ZIP.
> That makes is 67MB.
>
> I really like your new README.txt file.  It has a lot of good info.
>
> -Rob

Mime
View raw message