incubator-odf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Devin Han (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ODFTOOLKIT-298) XLST-Runner and Validator aren't compatible with Java 5
Date Thu, 15 Dec 2011 17:00:31 GMT

    [ https://issues.apache.org/jira/browse/ODFTOOLKIT-298?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13170345#comment-13170345
] 

Devin Han commented on ODFTOOLKIT-298:
--------------------------------------

Realize the function of TransformerFactory newInstance(String factoryClassName, ClassLoader
classLoader) by ourselves.

Fixed this issue.
                
> XLST-Runner and Validator aren't compatible with Java 5
> -------------------------------------------------------
>
>                 Key: ODFTOOLKIT-298
>                 URL: https://issues.apache.org/jira/browse/ODFTOOLKIT-298
>             Project: ODF Toolkit
>          Issue Type: Bug
>          Components: validator, xslt-runner
>            Reporter: Devin Han
>            Assignee: Devin Han
>
> In XSLT-Runner
> 1. ODFURIResolver.resolve() called String.isEmpty(), which only exists in Java 6.  Trivial
fix is to test for length() ==0.
> 2. ODFXSLTRunnner.runXSLT() calls a 2-parameter newInstance() method that exists only
in Java 6:
> http://docs.oracle.com/javase/6/docs/api/javax/xml/transform/TransformerFactory.html#newInstance%28java.lang.String,
java.lang.ClassLoader%29
> In Validator
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile
(default-compile) on project odfvalidator: Compilation failure
> [ERROR] Failure executing javac, but could not parse the error:
> [ERROR] javac: invalid flag: -s
> caused by:
>  <configuration>
>                     <source>1.5</source>
>                     <target>1.5</target>
>                     <meminitial>512m</meminitial>
>                     <maxmem>1024m</maxmem>
>                     <showDeprecation>true</showDeprecation>
>                 </configuration>
> it was hard-coded to 1.6 before in pom.xml.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message