incubator-npanday-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lars Corneliussen ...@lcorneliussen.de>
Subject Re: declaring system dependencies
Date Thu, 18 Apr 2013 05:32:15 GMT
Hi,

this should also work with <type>dotnet-gac</type> or gac_32

    <dependency>
      <groupId>System.Web.Routing</groupId>
      <artifactId>System.Web.Routing</artifactId>
      <version>4.0.0.0</version>
      <type>gac_msil4</type>
      <classifier>31bf3856ad364e35</classifier>
    </dependency>



Am 25.03.2013 um 19:12 schrieb David Durham <david.durham.jr@gmail.com>:

> Looks like I can do this:
> 
>    <dependency>
>      <groupId>mono</groupId>
>      <artifactId>System.Web</artifactId>
>      <version>2.0.0.0</version>
>      <type>dotnet-library</type>
>      <scope>system</scope>
>      <systemPath>/usr/lib/mono/2.0/System.Web.dll</systemPath>
>    </dependency>
> 
> 
> And I guess I put these in profiles activated by platform so that I
> can build on linux and windows.  This is not ideal, but maybe not all
> that bad.  I'll post my profiles if it get them working.
> 
> -Dave
> 
> 
> On Mon, Mar 25, 2013 at 12:59 PM, David Durham
> <david.durham.jr@gmail.com> wrote:
>> I believe I've successfully declared a dependency to log4net, as
>> mentioned in a previous email.  I have a pom entry like so:
>> 
>>  <dependencies>
>>    <dependency>
>>      <groupId>log4net</groupId>
>>      <artifactId>log4net</artifactId>
>>      <version>1.2.11</version>
>>      <type>dotnet-library</type>
>>    </dependency>
>>  </dependencies>
>> 
>> And I ran a command like this:
>> 
>> [ddurham@dfwddurham lib]$ mvidn log4net.dll log4net log4net 1.2.11 dll
>> [ddurham@dfwddurham lib]$ cat ~/bin/mvidn
>> mvn install:install-file -Dfile=log4net.dll \
>>                         -DgroupId=log4net \
>>                         -DartifactId=log4net \
>>                         -Dversion=1.2.11 \
>>                         -Dpackaging=dll
>> 
>> This caused a maven error about the missing log4net dependency to go
>> away.  I am not facing an error about missing "System" dependencies.
>> For instance:
>> 
>>    The type or namespace name `IHttpHandler' does not exist in the
>> namespace `System.Web'. Are you missing an assembly reference?
>> 
>> I have added the System.Web reference to my project, which did not
>> resolve the issue.  Do I need to declare a <scope>system</scope>
>> dependency for System.Web to my pom file?  I have search docs and the
>> web trying to find an example of this and haven't found anything.
>> Leads me to believe that the issue is something else.  Any ideas?
>> 
>> Thanks,
>> Dave


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message