incubator-npanday-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergio Rupena" ...@247e.com>
Subject RE: npanday with maven 3 issues
Date Wed, 07 Sep 2011 21:05:58 GMT
Hello,

Thanks for your comments. I was about to file a new bug in the npanday
issue tracker but then decided to have a deeper look. It turns out that
the issue is not related to npanday, but is the behavior of maven 3.
I'll quickly explain what the issue was: 

The project was using the maven-dependency-plugin together with the
copy-dependencies goal ( in the parent pom)
 
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-dependency-plugin</artifactId>
<version>2.2</version>
<executions>
  <execution>
	<id>copy-dependencies</id>
	<goals>
	  <goal>copy-dependencies</goal>
	</goals>
	....
  </execution>
</executions>
</plugin>

One project dependency was a GAC dll which was of course not in the
repository.  Interestingly this was no problem with maven 2, but with
the latest version of maven I ran into this issue. 

Sergio

-----Original Message-----
From: Lars Corneliussen [mailto:me@lcorneliussen.de] 
Sent: Wednesday, September 07, 2011 10:29 PM
To: npanday-users@incubator.apache.org
Subject: Re: npanday with maven 3 issues

hi,

I usually use maven 3, but not with gac references. I think for maven 2
we intercept the right places to help resolving the artifacts from gac;
maybe we have to hook it up differently for maven 3 (google IOC)

for building the npanday trunk, first run the mv3-bootstrap bat in
npanday trunk root (don't remember the full file name); this is
necessary, since mvn3 can't resolve plugin deps within a reactor build -
they have to be in the repo. 

hope that helps
_
Lars

--
Message sent from mobile device

Am 07.09.2011 um 16:04 schrieb "Sergio Rupena"
<sergio.rupena@gmail.com>:

> Hi,
> 
> It looks like npanday 1.4.1-INCUBATING does not fully support maven 3 
> (3.0.3).
> 
> For GAC dependencies (type = gac_msil) I would define a dependency in 
> the pom as follows:
> 
>    <dependency>
>      <groupId>Microsoft</groupId>
>      <artifactId>System.ComponentModel.DataAnnotations</artifactId>
>      <version>3.5.0.0</version>
>      <classifier>31bf3856ad364e35</classifier>
>      <type>gac_msil</type>
>    </dependency>
> 
> I don't have the dependency in my repository and when I compile with 
> maven 2 everything works fine. However with maven 3, I get an error 
> that maven is not capable of finding the pom in any repository.
> Is this a maven or an npanday related issue? I had to upload the 
> mentioned dll from GAC to my repository in order to make my build. 
> Maybe I am doing something wrong. Anyone tried to have gac_msil 
> dependencies and build with maven 3 ?
> Also building npanday itself with maven 3 did not work for me. Any 
> plans for stronger maven 3 support?
> 
> Best regards,
> Sergio
> 

Mime
View raw message