incubator-npanday-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: npanday with maven 3 issues
Date Wed, 07 Sep 2011 17:12:09 GMT
I predominantly use Maven 2.2.1 with NPanday, but I believe it was made to work with 3 for
the 1.4.0 release.

Can you file an issue with the specific errors you get in both cases? You should not need
to upload anything for GAC dependencies, and it should build with Maven 3 as well.

- Brett

On 08/09/2011, at 12:04 AM, Sergio Rupena wrote:

> Hi,
> 
> It looks like npanday 1.4.1-INCUBATING does not fully support maven 3
> (3.0.3).
> 
> For GAC dependencies (type = gac_msil) I would define a dependency in the
> pom as follows:
> 
>    <dependency>
>      <groupId>Microsoft</groupId>
>      <artifactId>System.ComponentModel.DataAnnotations</artifactId>
>      <version>3.5.0.0</version>
>      <classifier>31bf3856ad364e35</classifier>
>      <type>gac_msil</type>
>    </dependency>
> 
> I don't have the dependency in my repository and when I compile with maven 2
> everything works fine. However with maven 3, I get an error that maven is
> not capable of finding the pom in any repository.
> Is this a maven or an npanday related issue? I had to upload the mentioned
> dll from GAC to my repository in order to make my build. Maybe I am doing
> something wrong. Anyone tried to have gac_msil dependencies and build with
> maven 3 ?
> Also building npanday itself with maven 3 did not work for me. Any plans for
> stronger maven 3 support?
> 
> Best regards,
> Sergio
> 

--
Brett Porter
brett@apache.org
http://brettporter.wordpress.com/
http://au.linkedin.com/in/brettporter





Mime
View raw message