incubator-npanday-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adelita Padilla <apadi...@maestrodev.com>
Subject Re: Trouble Getting Going with 1.4.0
Date Mon, 09 May 2011 02:22:22 GMT
Hi Eric,


On Mon, May 9, 2011 at 10:00 AM, Eric Kolotyluk <eric.kolotyluk@gmail.com>wrote:

>  OK, there was no settings.xml in my ~/.m2 so I added the default one.
>
> I have been using Maven and m2e for months never needing to do that, so I
> don't understand why NPanday needs it there? I would consider that a bug.
>
> Now when I try to add an artifact it complains
>
>
>
> How am I supposed to know where that is?
>


You can add that dependency by configuring the remote repository.  Here's
the documentation for that ->
http://incubator.apache.org/npanday/docs/1.4.0-incubating/guide/vs/configureRepository.html



>
> I've been struggling with NPanday for hours just because I want to try to
> add a dependency to log4net, and I still cannot see any light at the end of
> the tunnel.
>
> It is so much easier to use the Sonatype plugin for Eclipse.
>
> By the way, the file npanday-repository-builder-1.4.0-incubating-bin.tar.gz
> had no npanday directory in it, so I'm using the one from the 1.3.1 release.
>


The npanday directory is located in /repository/releases/org/apache/npanday.




>
> Cheers, Eric
>
>
> On 2011-05-08 6:37 PM, Deng Ching wrote:
>
> Hi Eric,
>
>  The message from the pop-up was just a warning, so you should still be
> able to add an artifact. What happens afterwards when you click OK?
>
>  The settings.xml file btw, is a configuration file used by Maven where
> you can set the repositories that you want Maven to look for
> artifacts/dependencies of your project when you build it. It is also used by
> NPanday in a similar way during project import, artifact re-sync and when
> building your project.
>
>  Thanks,
> Deng
>
> On Mon, May 9, 2011 at 9:23 AM, Eric Kolotyluk <eric.kolotyluk@gmail.com>wrote:
>
>>  I used
>>
>>    - npanday-repository-builder-1.4.0-incubating-bin.tar.gz
>>    - npanday-installer-1.4.0-incubating.msi
>>
>> to set up NPanday, and I was able to set up my POMs ok.
>>
>> I'm trying to get NPanday to work with Visual Studio 2010, but when I try
>> to add and artifact I get
>>
>>
>>
>> Does anyone have any ideas on how to fix this?
>>
>> Cheers, Eric
>>
>
>

Thanks,

--

liit

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message