incubator-npanday-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josimpson Ocaba <joc...@maestrodev.com>
Subject Re: using npanday to build WPF applications
Date Thu, 05 May 2011 22:53:28 GMT
How was that dependency added? Can you post the dependency tag here. You can
also try installing the dependency library first by doing a current project
install on the dependency file and then using add maven artifact on the
project using the dependency.

Hope this helps,

Joe

On Fri, May 6, 2011 at 6:42 AM, Khai Do <khai.do@impinj.com> wrote:

> Thanks for the tip Josimpson.  I didn't use the VS plugin before just hand
> created the pom.xml and pointed to dependencies straight from the npanday
> repository.  Now I just tried installing the npanday-1.3-incubating.msi
> installer (VS add-in + repository), generated the pom from VS 2010 then ran
> a maven build.  My VS solution contains 7 projects, so it creates a
> multi-module project with a parent pom.  When I run the build the first 6
> modules (all libraries) built without error and it gets installed into the
> my local repository under my home folder.  When npanday attempts to build
> the last module (WPF winexe) it fails because it cannot resolve a transitive
> dependency, one of the modules that got built before this module. It seems
> to be looking in the wrong location for some reason.  The build attempts to
> look in my "<local repro>/bin/Dashboard/.." folder which isn't correct
> because 'bin' isn't the groupId that was setup when the pom files were
> created. It should be something like "<local repro>/Microsoft/Dashboard/..".
>  This is the actual error..
>
> Missing:
> ----------
> 1) bin:Dashboard.LlrpInterop:dotnet-library:Debug
>
> The library does exist, it's just in "<local repro>/Microsoft/Dashboard/.."
>
> Have you run into this problem with your builds?
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message