incubator-npanday-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Kolotyluk <eric.koloty...@gmail.com>
Subject Re: Trouble Getting Going with 1.4.0
Date Mon, 09 May 2011 17:41:56 GMT
Please see below...

On 2011-05-09 8:29 AM, Lars Corneliussen wrote:
> Please see below.
>
> Am 09.05.11 17:06, schrieb Eric Kolotyluk:
>> Please see below.
>>
>> On 2011-05-09 1:55 AM, Lars Corneliussen wrote:
>>> Am 09.05.11 05:00, schrieb Eric Kolotyluk:
>>>> OK, I added
>>>>
>>>> <dependency>
>>>> <groupId>log4net</groupId>
>>>> <artifactId>log4net</artifactId>
>>>> <version>1.2.10.0-SNAPSHOT</version>
>>>> <name>Log for .Net</name>
>>>> </dependency>
>>> Just interested: Where is this dependency located? Do we have it 
>>> uploaded somewhere?  Did you build and upload it somewhere?
>> I have no idea where this is located - I thought the point of Maven 
>> and having a central repository was I should not have to care.
>>
>> I took the XML from some place I found on a Google search, hoping 
>> that if someone else had used it, then it might work for me.
> This is years ago :-) 
> http://maven.40175.n5.nabble.com/How-to-make-manual-artifacts-using-classifiers-td328342.html
>
> We do not maintain a repository with all open source artifacts, like 
> Maven Central. This had to be done by each individual project, as it 
> is been done in Java.
>
> Again, adoption is not broad enough.
>
> So we find ourselves deploying things we need in our private 
> enterprise repository (Archiva, Artifactory or Nexus). Then we can 
> decide ourselves on group ids, e.g.
>
> Visual Studio/MS just released Nuget, which already has quite some 
> libs online. It also comes with dependency management. We plan to 
> integrate with the nuget Gallery in some future version. (like 
> Sonatype Tycho integrates with Eclipse p2-Repos)
>

OK, I'm beginning to understand - I have been spoiled by m2e and Java ;-)
I need to lower my expectations until the .NET world catches up.

So, in the mean time it's up to me to find other people who have 
repositories I can tap into? Fair enough, I've had to do that a few 
times with Maven. Unfortunately I have not been able to find a Maven 
repository (via Google) for log4net, at least it seems Apache don't have 
one.  Does anyone have any advice on how to find external repositories 
for .NET artifacts (i.e. DLLs)?

>>>>
>>>> to my POM, but if I try to do a build I get
>>>>
>>>>    Error in Starting Maven Process: Value cannot be null.
>>>>    Parameter name: path1
>>> Could you provide a stack trace?
>>
>> Where would I find the stack trace?
>>
>> By the way, whenever I start Visual Studio I keep getting the 
>> following message
>>
>>
> I have seen that before, but I can't remember what the reason was. 
> Maybe /_*Joe or liit*_/ can help?

OK, hopefully someone will respond. It's a little frustrating that I 
cant' even get a simple build to work.

>>>>
>>>> I still cannot believe how hard this is to get working.
>>>>
>>>> Does anyone have any ideas on what I should try next.
>>>>
>>>> Cheers, Eric
>>>>
>>>>
>>>> On 2011-05-08 7:32 PM, Eric Kolotyluk wrote:
>>>>> Please see below...
>>>>>
>>>>> On 2011-05-08 7:22 PM, Adelita Padilla wrote:
>>>>>>
>>>>>> Hi Eric,
>>>>>>
>>>>>>
>>>>>> On Mon, May 9, 2011 at 10:00 AM, Eric Kolotyluk 
>>>>>> <eric.kolotyluk@gmail.com <mailto:eric.kolotyluk@gmail.com>>
wrote:
>>>>>>
>>>>>>     OK, there was no settings.xml in my ~/.m2 so I added the 
>>>>>> default one.
>>>>>>
>>>>>>     I have been using Maven and m2e for months never needing to do
>>>>>>     that, so I don't understand why NPanday needs it there? I would
>>>>>>     consider that a bug.
>>>>>>
>>>>>>     Now when I try to add an artifact it complains
>>>>>>
>>>>>>
>>>>>>
>>>>>>     How am I supposed to know where that is?
>>>>>>
>>>>>>
>>>>>>
>>>>>> You can add that dependency by configuring the remote 
>>>>>> repository.  Here's the documentation for that -> 
>>>>>> http://incubator.apache.org/npanday/docs/1.4.0-incubating/guide/vs/configureRepository.html
>>>>>>
>>>>> Yes, I found that page already, but it does not give me a URL for 
>>>>> any remote repositories. How am I supposed to know where they are?
>>>>>
>>>>> For example, how am I supposed to know how to find log4net?
>>>>>>
>>>>>>
>>>>>>     I've been struggling with NPanday for hours just because I want
>>>>>>     to try to add a dependency to log4net, and I still cannot see

>>>>>> any
>>>>>>     light at the end of the tunnel.
>>>>>>
>>>>>>     It is so much easier to use the Sonatype plugin for Eclipse.
>>>>>>
>>>>>>     By the way, the file
>>>>>>     npanday-repository-builder-1.4.0-incubating-bin.tar.gz had no
>>>>>>     npanday directory in it, so I'm using the one from the 1.3.1

>>>>>> release.
>>>>>>
>>>>>>
>>>>>>
>>>>>> The npanday directory is located in 
>>>>>> /repository/releases/org/apache/npanday.
>>>>>>
>>>>>>
>>>>> Ahhhh, that's different than 1.3.1. Thanks.
>>>>>
>>>>>>
>>>>>>     Cheers, Eric
>>>>>>
>>>>>>
>>>>>>     On 2011-05-08 6:37 PM, Deng Ching wrote:
>>>>>>>     Hi Eric,
>>>>>>>
>>>>>>>     The message from the pop-up was just a warning, so you should
>>>>>>>     still be able to add an artifact. What happens afterwards
when
>>>>>>>     you click OK?
>>>>>>>
>>>>>>>     The settings.xml file btw, is a configuration file used by

>>>>>>> Maven
>>>>>>>     where you can set the repositories that you want Maven to
look
>>>>>>>     for artifacts/dependencies of your project when you build

>>>>>>> it. It
>>>>>>>     is also used by NPanday in a similar way during project import,
>>>>>>>     artifact re-sync and when building your project.
>>>>>>>
>>>>>>>     Thanks,
>>>>>>>     Deng
>>>>>>>
>>>>>>>     On Mon, May 9, 2011 at 9:23 AM, Eric Kolotyluk
>>>>>>> <eric.kolotyluk@gmail.com <mailto:eric.kolotyluk@gmail.com>>
wrote:
>>>>>>>
>>>>>>>         I used
>>>>>>>
>>>>>>>             * 
>>>>>>> npanday-repository-builder-1.4.0-incubating-bin.tar.gz
>>>>>>>             * npanday-installer-1.4.0-incubating.msi
>>>>>>>
>>>>>>>         to set up NPanday, and I was able to set up my POMs ok.
>>>>>>>
>>>>>>>         I'm trying to get NPanday to work with Visual Studio
2010,
>>>>>>>         but when I try to add and artifact I get
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>         Does anyone have any ideas on how to fix this?
>>>>>>>
>>>>>>>         Cheers, Eric
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>> Thanks,
>>>>>>
>>>>>> -- 
>>>>>>
>>>>>> liit
>>>>
>>>
>

Mime
View raw message