incubator-nmaven-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sisb...@apache.org
Subject svn commit: r540716 - /incubator/nmaven/trunk/site/src/site/apt/getting-started.apt
Date Tue, 22 May 2007 19:41:58 GMT
Author: sisbell
Date: Tue May 22 12:41:57 2007
New Revision: 540716

URL: http://svn.apache.org/viewvc?view=rev&rev=540716
Log:
Updated site docs with additional build instructions and FxCop doc.

Modified:
    incubator/nmaven/trunk/site/src/site/apt/getting-started.apt

Modified: incubator/nmaven/trunk/site/src/site/apt/getting-started.apt
URL: http://svn.apache.org/viewvc/incubator/nmaven/trunk/site/src/site/apt/getting-started.apt?view=diff&rev=540716&r1=540715&r2=540716
==============================================================================
--- incubator/nmaven/trunk/site/src/site/apt/getting-started.apt (original)
+++ incubator/nmaven/trunk/site/src/site/apt/getting-started.apt Tue May 22 12:41:57 2007
@@ -34,10 +34,11 @@
 
   [[1]] {{{ http://java.sun.com/javase/downloads/index_jdk5.jsp} JDK 5.0 Update x}}
 
-  [[2]] {{{http://msdn2.microsoft.com/en-us/netframework/default.aspx} Microsoft .NET Framework}}
(2.0+)
-  OR {{{http://www.mono-project.com} Mono}} (1.2.3.1+). Note that the 2.0+ framework
-  (either MONO or Microsoft) is required to run NMaven but you can still target 1.1 for your
builds provided that the 1.1 version
-  is installed.
+  [[2]] For Microsoft builds you will need both {{{http://msdn2.microsoft.com/en-us/downloads/default.aspx}
Microsoft .NET Framework}} (2.0+)
+     AND {{{http://msdn2.microsoft.com/en-us/downloads/default.aspx} NET Framework 2.0 SDK}}.
For Mono builds, you will need
+     {{{http://www.mono-project.com} Mono}} (1.2.3.1+). Note that the 2.0+ framework
+  (either MONO or Microsoft) is required to run NMaven, but you can still target 1.1 for
your builds provided that the 1.1 version
+  is also installed.
 
   [[3]] Subversion client 1.3+ (although 1.4 will soon be required). Click here for
  {{{ http://subversion.tigris.org/servlets/ProjectDocumentView?documentID=35379&showInfo=true}
Windows Subversion Client}}.
@@ -46,10 +47,17 @@
 
   [[5]] {{{http://maven.apache.org/download.html} Maven 2.0.4 or higher}}
 
-  [[]]
+[]
 
-  If you are planning on using NMaven with Visual Studio 2005, you will also need VS installed
-  prior to building NMaven.
+  Optional programs that need to be downloaded separately (and are not required for the build)
include:
+
+  [[1]] {{{http://www.gotdotnet.com/Team/FxCop/} FxCop 1.35 (Windows Only)}}. FxCop is a
code analysis tool that checks
+  .NET managed code assemblies for conformance to the Microsoft .NET Framework Design Guidelines.
+
+  [[2]]   Visual Studio 2005 Standard or higher is needed to use the NMaven Addin
+    (Visual Studio Express Edition will not work)
+
+[]
 
 ** Bootstrap Build
 
@@ -84,7 +92,7 @@
 
   [[2]] If compiling on Windows with either Microsoft or Mono:
 
-   [[a]] the csc (or gmcs) executable directory AND the .NET SDK install root (containing
xsd, wsdl) should be located on the system path.
+   [[a]] <<the csc (or gmcs) executable directory AND the .NET SDK install root (containing
xsd, wsdl) should be located on the system path>>.
     For Mono the executable directory and the SDK install root are the same. This configuration
is only needed for the
     initial bootstrap build and may be removed afterwards.
 
@@ -98,7 +106,7 @@
   [[3]] Execute bootstrap-build.bat (or bootstrap-build.sh) from the nmaven directory. If
you want to compile with
   Visual Studio 2005 support (Windows only) execute: bootstrap-build.bat -DVisualStudio2005
 
- During step (1), you may receive an error similar to the following:
+ During step (1), if you receive an error similar to the following, will need to upgrade
to subversion 1.4 or higher:
 
 +----+
 
@@ -106,7 +114,34 @@
  please get a newer Subversion client
 +----+
 
- In this case will need to upgrade to subversion 1.4 or higher.
+ During step (3) if you can't build, the most common reason is that the paths are not set
correctly (see 2(a) above). To verify try,
+
++----+
+ xsd
++----+
+
+ If you see the error message below, make sure that Mono or the SDK for Microsoft is installed
on the classpath.
+
++----+
+'xsd' is not recognized as an internal or external command
+
+or
+
+xsd: command not found
++----+
+
+ Also try commands for: "nunit-console" and "csc". If either of these gives a command not
found, then you need to add
+  them to the system path. If you still can't build, you will need to capture the debug output.
Type
+
++----+
+bootstrap-build.bat -X > out.log
++----+
+
+ and report the error to either
+
+ * {{{http://jira.codehaus.org/browse/NMAVEN} NMaven Issue Tracking}}
+
+ * {{{mailto:nmaven-dev@incubator.apache.org} Post to Mailing List}}
 
 ** Linux Specific Setup
 
@@ -560,8 +595,26 @@
 
 * {FxCop Maven Plugin}
 
- Make sure that FxCopCmd is located within your path and then type:
+ Make sure that FxCopCmd is installed and located within your path.
+
+ Then:
+ 
+ [[1]] Go to your directory containing the pom (it may be a parent pom containing multiple
modules).
+
+ [[2]] Install the project: mvn install
+
+ [[3]] Type one of the following commands
+
+[]
+
+  For a single module install or a multi-module, non-aggregated reports, type:
 
 +----+
 mvn org.apache.maven.dotnet.plugins:maven-fxcop-plugin:fxcop
++----+
+
+ For a mult-module, aggregated report, type:
+
++----+
+mvn org.apache.maven.dotnet.plugins:maven-fxcop-plugin:aggregate
 +----+



Mime
View raw message