incubator-mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Mahler (JIRA)" <>
Subject [jira] [Created] (MESOS-524) JVM tests are flaky on OSX.
Date Tue, 25 Jun 2013 01:14:20 GMT
Benjamin Mahler created MESOS-524:

             Summary: JVM tests are flaky on OSX.
                 Key: MESOS-524
             Project: Mesos
          Issue Type: Bug
            Reporter: Benjamin Mahler
            Assignee: Benjamin Mahler

I'm seeing the following issue on a regular occasion:

[ RUN      ] ZooKeeperStateTest.FetchAndStoreAndFetch
2013-06-24 12:18:21.277 mesos-tests[59429:f07] Apple AWT Java VM was loaded on first thread
-- can't start AWT.
java.lang.InternalError: Can't start the AWT because Java was started on the first thread.
 Make sure StartOnFirstThread is not specified in your application's Info.plist or on the
command line
	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
	at java.lang.ClassLoader.loadLibrary0(
	at java.lang.ClassLoader.loadLibrary(
	at java.lang.Runtime.loadLibrary0(
	at java.lang.System.loadLibrary(
	at Method)
	at java.awt.Toolkit.loadLibraries(
	at java.awt.Toolkit.<clinit>(
	at sun.awt.AppContext$
	at sun.awt.AppContext$
	at Method)
	at sun.awt.AppContext.initMainAppContext(
	at sun.awt.AppContext.access$200(
	at sun.awt.AppContext$
	at Method)
	at sun.awt.AppContext.getAppContext(
	at com.sun.jmx.trace.Trace.out(
	at com.sun.jmx.trace.Trace.isSelected(
	at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.isTraceOn(
	at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerDynamicMBean(
	at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerObject(
	at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(
	at com.sun.jmx.mbeanserver.JmxMBeanServer$
	at Method)
	at com.sun.jmx.mbeanserver.JmxMBeanServer.initialize(
	at com.sun.jmx.mbeanserver.JmxMBeanServer.<init>(
	at com.sun.jmx.mbeanserver.JmxMBeanServer.<init>(
	at com.sun.jmx.mbeanserver.JmxMBeanServer.newMBeanServer(
	at org.apache.zookeeper.jmx.MBeanRegistry.register(
	at org.apache.zookeeper.server.ZooKeeperServer.registerJMX(
	at org.apache.zookeeper.server.ZooKeeperServer.startup(
	at org.apache.zookeeper.server.NIOServerCnxn$Factory.startup(
Exception in thread "main" Caught a JVM exception, not propagating

It appears the fix is potentially to set NOAWT=1 in our build environment. Need to dig further.

Some pointers:

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message