incubator-mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benabbas Aboubakr El Hacen (JIRA)" <>
Subject [jira] [Commented] (MESOS-464) mesos 0.10.0 fails to build on ubutu 13.04
Date Sun, 12 May 2013 09:09:16 GMT


Benabbas Aboubakr El Hacen commented on MESOS-464:

I have another question, this might seem silly, but i need to figure it out,  I want to write
my own framework, I have read what was written in the documentation about the subject, I would
like to know how can I get one of the example frameworks in mesos into an IDE (eclipse in
my case) so that i can run modifications on it and subsequently build my own, what should
I import to the IDE (files and libraries) and how to do it, suppose i want to first modify
test-framework (written in c++ or JAVA), I would be glad if you could help me with this.
> mesos 0.10.0 fails to build on  ubutu 13.04 
> --------------------------------------------
>                 Key: MESOS-464
>                 URL:
>             Project: Mesos
>          Issue Type: Bug
>          Components: general
>    Affects Versions: 0.10.0
>         Environment: Ubuntu 13.04 32 bits, Ubuntu 12.04 LTS 32 bits
>            Reporter: Benabbas Aboubakr El Hacen
>              Labels: newbie
>             Fix For: 0.13.0
> I try to build mesos 0.10.0 on my machine by following the instructions on the README
file, but when i run make I get the following :
> ////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
> In file included from ../third_party/boost-1.37.0/boost/uuid/random_generator.hpp:12:0,
>                  from ../third_party/boost-1.37.0/boost/uuid/uuid_generators.hpp:17,
>                  from ../../third_party/libprocess/include/stout/uuid.hpp:11,
>                  from ../../src/master/master.cpp:31:
> ../third_party/boost-1.37.0/boost/uuid/seed_rng.hpp: In member function 'void boost::uuids::detail::seed_rng::sha1_random_digest_()':
> ../third_party/boost-1.37.0/boost/uuid/seed_rng.hpp:153:53: warning: ignoring return
value of 'size_t fread(void*, size_t, size_t, FILE*)', declared with attribute warn_unused_result
> make[2]: *** [master/libmesos_no_third_party_la-master.lo] Error 1
> make[2]: Leaving directory `/home/aboubakr/Development/mesos-0.10.0/build/src'
> make[1]: *** [all] Error 2
> make[1]: Leaving directory `/home/aboubakr/Development/mesos-0.10.0/build/src'
> make: *** [all-recursive] Error 1
> /////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
> I tried to find a solution to that by reading the other issues posted before, but i could
not understand them, besides they were for older version(12.04), I would be grateful if you
tell me in details the steps needed to build mesos on my machine 

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message