incubator-mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From praveenesh kumar <>
Subject Re: Problems in starting mesos
Date Fri, 21 Sep 2012 06:42:22 GMT
Thanks Benjamin.

1. I was wondering how can I run mesos-master and slaves as daemon process.
Nohup is giving me issues to launch them from remotely.

3. I have build mesos from trunk and starting meso master and slave by ---


*nohup /usr/local/mesos-spark/mesos/bin/
--log_dir=/usr/local/mesos-spark/mesos/work >> /tmp/mesos-master.txt &*
*ln -s lt-mesos-master.INFO mesos-master.INFO*
*ln -s lt-mesos-master.ERROR mesos-master.ERROR*
*ln -s lt-mesos-master.WARNING mesos-master.WARNING*

Mesos-slave  --- (Note I need to create links to all log files to enable
logging from mesos web url)

*nohup /usr/local/mesos-spark/mesos/bin/ --master=br9:5050
--log_dir=/usr/local/mesos-spark/mesos/work >> /tmp/mesos-slave.txt &*

*cd /usr/local/mesos-spark/mesos/*
*chmod 777 -R work*
*cd work*
*ln -s lt-mesos-slave.ERROR mesos-slave.ERROR*
*ln -s lt-mesos-slave.WARNING mesos-slave.WARNING*
*ln -s lt-mesos-slave.INFO mesos-slave.INFO*

I see only these suspicious lines in lt-mesos-master.ERROR

Log line format: [IWEF]mmdd hh:mm:ss.uuuuuu threadid file:line] msg
E0918 04:28:37.111768 28729 files.cpp:92] Error attaching path
'/usr/local/mesos-spark/mesos/work/mesos-master.INFO': Failed to
canonicalize /usr/local/mesos-spark/mesos/work/mesos-master.INFO into an
absolute path
E0918 04:28:37.112239 28731 master.cpp:535] Failed to attach log file:
Failed to canonicalize /usr/local/mesos-spark/mesos/work/mesos-master.INFO
into an absolute path


On Wed, Sep 19, 2012 at 12:26 PM, Benjamin Mahler <>wrote:

> 1. You could run it as a daemon, what you're doing with nohup is fine as
> well.
> 2. The webui shows various resource statistics: [image: Inline image 2]
> *Total memory* indicates the total amount of memory available on all the
> slaves.
> Total Memory should equal Used + Idle + Offered
> *
> *
> *Used:* Memory used by the frameworks.
> *Offered:* This memory has been offered but the framework hasn't
> responded yet.
> *Idle:* Any remaining memory in the system.
> 3. Are you running off trunk or a release? What is the command line you're
> running to start the master? Can you provide the master's log output?
> On Tue, Sep 18, 2012 at 11:57 PM, praveenesh kumar <>wrote:
>> Hi all,
>> I have been able to successfully build and install mesos on my physical
>> nodes. I can see the mesos web-url with list of mesos slaves. However I am
>> finding few difficulties w.r.t to following things:
>> *1. How to start and as a background
>> process
>> ? *
>> I am seeing all my output on the console. Since I want to remotely start
>> the service on the cluster, I tried using nohup. Its working for now, but
>> is it the right way? I am hoping there should be better way to do that.
>> *2.* *Whatever memory I am seeing on the mesos-web url, is it the total
>> memory or the free memory available on my system ?*
>> I am seeing very low memory (0.001 GB) -- Does it indicate the current
>> available memory ?
>> 3. I have enable the "log_dir" directory, while starting the mesos-master
>> and slaves. I can see the logs for my slave machines from mesos web url,
>> but not able to see logs for my master. Its saying *"Failed to Initialize
>> .... Retrying"*. I can see work directory is there as well as the logs are
>> also there. Set the permission to 777 also. Still no success.
>> Any help on the above to understand mesos, would be very helpful.
>> Regards,
>> Praveenesh

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message