incubator-mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lai Zhou (Updated) (JIRA)" <>
Subject [jira] [Updated] (MESOS-151) failed to create ZooKeeper znode! (invalid acl)
Date Sun, 26 Feb 2012 14:44:48 GMT


Lai Zhou updated MESOS-151:

    Component/s: master
> failed to create ZooKeeper znode! (invalid acl)
> -----------------------------------------------
>                 Key: MESOS-151
>                 URL:
>             Project: Mesos
>          Issue Type: Bug
>          Components: master
>            Reporter: Lai Zhou
> First ,I add the url parameter to the meso.conf :
> url=zoo://
> then I start the zookeeper service,and exec mesos-master to start a master on my machine,but
there's a error when the master try to create a znode:
> I0108 15:23:41.391342 10733 detector.cpp:404] Trying to create znode '/znode' in ZooKeeper
> 2012-01-08 15:23:41,391:10732(0xb7870b70):ZOO_DEBUG@zoo_acreate@2489: Sending request
xid=0x4f09447e for path [/znode] to
> 2012-01-08 15:23:41,399:10732(0xb5effb70):ZOO_DEBUG@zookeeper_process@1980: Queueing
asynchronous response
> 2012-01-08 15:23:41,399:10732(0xb56feb70):ZOO_DEBUG@process_completions@1817: Calling
COMPLETION_STRING for xid=0x4f09447e rc=-114
> failed to create ZooKeeper znode! (invalid acl) (detector/detector.cpp:410)
> After going deep into the code (detector/detector.cpp:410), I just test some commands
by like that:
> create /znode "" {2,{{1,{"world", "anyone"}},{ 31,{"auth", ""} }} }
> then a new node was created. But when I use mesos do the same thing ,it can't work.
> I guess it might be a zookeeper problem,so would you guys do me a favor?

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message