incubator-mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Charles Reiss (Created) (JIRA)" <>
Subject [jira] [Created] (MESOS-160) Installed contains impossible dependencies
Date Thu, 23 Feb 2012 20:28:49 GMT
Installed contains impossible dependencies

                 Key: MESOS-160
             Project: Mesos
          Issue Type: Bug
            Reporter: Charles Reiss

Because of third_party, the that we install contains dependencies that are likely
to make libtool links fail against an installed mesos:

(e.g. from a build in a Ubuntu VM)

dependency_libs=' -L../third_party/leveldb -lleveldb -lz /usr/lib/     /usr/lib/
-lpthread -L/usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/server -lrt

I believe the glog and libev dependencies come through libprocess. The leveldb link comes
from src/

Since we carefully link libmesos to not have require any strange dependency links, we could
probably just not install the .la file or strip dependency_libs from it as a quick fix to
this problem.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message