incubator-mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthew Rathbone <>
Subject Enjoying mesos - building on OSX
Date Fri, 27 Jan 2012 03:27:34 GMT
Hey all, 

I've been looking into how to best migrate our current hadoop deployment from EMR to a more
production-friendly permanent setup. During my research I came across mesos, tried it on ec2
and was hooked!

I'm looking to experiment with the system in preparing for a production roll out, but I'm
having issues building mesos on osx so that I can test locally.

I think it's an issue with autoconf, so I installed a new version through macports, but I'm
still getting the following errors when I run ./bootstrap:

m4/libtool.m4:1018: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4/libtool.m4:5305: _LT_LANG_CXX_CONFIG is expanded from...
m4/libtool.m4:785: _LT_LANG is expanded from...
m4/libtool.m4:768: LT_LANG is expanded from... the top level warning: LT_OUTPUT was called before LT_LANG
m4/libtool.m4:768: LT_LANG is expanded from... the top level
src/ `pkglibexecdir' is not a legitimate directory for `SCRIPTS'
autoreconf: automake failed with exit status: 1

Any idea how I would go about fixing that? 

Matthew Rathbone
Foursquare | Software Engineer | Server Engineering Team ( | @rathboma (
| 4sq (

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message