incubator-mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Turpin Jeff <>
Subject Re: Build issue on Mac OS X - Snow Leopard...
Date Fri, 22 Jul 2011 22:28:55 GMT
Hey Ben,

Sorry for sending this twice, I realized I didn't copy the mesos-dev list on
my previous response.... I am running OS X... I pulled down a fresh clone,
created a build directory, ran configure.template.macosx and make from the
build directory, and it still failed with the same error... The only place I
differ from your instructions on the Wiki is that I have installed Swig from
the official distribution and did not use macports, as I have brew installed
on my system and it can conflict with macports... Thanks for your help...


webui/slave/swig/slave_wrap.cpp:5058: error: OSWIGPY_SLICE_ARGĀ¹ was not
declared in this scope
make[1]: *** [webui/slave/swig/slave_wrap.o] Error 1

On 7/22/11 2:01 PM, "Benjamin Hindman" <> wrote:

> Hi Jeff,
> With a fresh clone, try creating a build directory and running configure and
> make in there. Let me know if you run into the same issue.
> BTW, are you on Linux or Mac OS X?
> Ben.
> On Jul 22, 2011, at 11:41 AM, Turpin Jeff wrote:
>> Hello everyone,
>> MESOS-23 still appears to be an issue -
>> The issue has been closed and marked as fixed but I am still unable to build,
>> still getting the same error as specified in MESOS-23.... I am building this
>> for the first time and am still somewhat unfamiliar with the project, so it
>> is possible I am doing something wrong.... Not sure if this is a Swig issue,
>> but I have version 2.0.4 installed.. Please let me know if I am being dense
>> and have missed something obvious, as I am eager to get Mesos running... Any
>> help would be greatly appreciated, Cheers!
>> Jeff

View raw message