incubator-lucy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Desilets, Alain" <Alain.Desil...@nrc-cnrc.gc.ca>
Subject [lucy-user] RE: Newbie, please help!
Date Wed, 23 Nov 2011 16:51:28 GMT
In fact, I tried to run the indexer.pl script that comes in the sample code on CPAN, and it
has the exact same problem. I can only run it once. The second time I run it, it gives me:

Couldn't completely remove 'seg_2'
        lucy_SegWriter_prep_seg_dir at C:\Users\Desiletsa\AppData\Roaming\.cpanplus\5.12.3\build\Lucy-0.2.2\core\Lucy\Index\SegWriter.c
line 90
        at C:/Perl/site/lib/Lucy.pm line 211
        Lucy::Index::Indexer::new('Lucy::Index::Indexer', 'index', './lucy', 'schema', 'Lucy::Plan::Schema=SCALAR(0x18db184)',
'create', 1, 'truncate', 1, ...)
called at indexer.pl line 51

All I changed in the script is the path of the index.

What am I doing wrong? 

Thx.

Alain
________________________________________
From: Desilets, Alain [Alain.Desilets@nrc-cnrc.gc.ca]
Sent: Wednesday, November 23, 2011 11:24 AM
To: lucy-user@incubator.apache.org
Subject: [lucy-user] Newbie, please help!

Hi all,

This is my first posting to this list. I am trying to figure out how to use Lucy, using the
instructions on this page:

http://incubator.apache.org/lucy/docs/perl/Lucy/Docs/Tutorial/BeyondSimple.html

I wrote the attached script, which works the first time I run it, but the second time I run
it, it gives me the following error:

---
rename from 'C:\Users\Desiletsa\Documents\eclipse_workspace\WeBiText\Spikes\lucy\schema.temp'
to 'C:\Users\Desiletsa\Documents\eclipse_workspace\WeBiText\Spikes\lucy\schema_1.json' failed:
File exists
lucy_Schema_write at C:\Users\Desiletsa\AppData\Roaming\.cpanplus\5.12.3\build\Lucy-0.2.2\core\Lucy\Plan\Schema.c
line 410
at C:/Users/Desiletsa/Documents/eclipse_workspace/WeBiText/Spikes/try_Lucy.pl line 32
---

If I delete the directory C:/Users/Desiletsa/Documents/eclipse_workspace/WeBiText/Spikes/lucy,
then I can run the script again.

What am I doing wrong?

Thx.

Alain D├ęsilets

Mime
View raw message