incubator-lucy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From goran kent <gorank...@gmail.com>
Subject Re: [lucy-user] Highlighting problem with latest trunk
Date Thu, 10 Nov 2011 09:13:40 GMT
On 11/9/11, Marvin Humphrey <marvin@rectangular.com> wrote:
>> Searching for a single term [email], results in words adjacent to
>> [email] being highlighted, but not always.
>
> https://issues.apache.org/jira/browse/LUCY-182?focusedCommentId=13147127&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-13147127

Just documenting an extra bit which might help towards debugging the above.

This bug might also account for the performance problem I've
encountered with setting up the highlighter objects - or is that not
related?

For example, I'm highlighting on title and body:

    my $body_highlighter = Lucy::Highlight::Highlighter->new(
        searcher  => $poly_searcher,
        query        => $query,
        field           => 'body',
        excerpt_length => 190,
    );

    my $title_highlighter = Lucy::Highlight::Highlighter->new(
        searcher  => $poly_searcher,
        query        => $query,
        field          => 'title',
        excerpt_length => 75,
    );

...basic stuff.

Completing each new() requires 4s *each*.  Somehow I don't recall this
being the case before :/

I'm happy to help by trying out test patches if you need - just chuck
'em my way.

cheers

Mime
View raw message