incubator-lucy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Karman <pe...@peknet.com>
Subject Re: [lucy-dev] Three class name changes
Date Thu, 07 Apr 2011 13:42:57 GMT
Nathan Kurz wrote on 04/04/2011 02:44 PM:

> Back to pragmatism:  if the goal is to get 0.1.0 out the door, stop
> worrying about naming stuff and release it.  But if the goal is to
> provide a better foundation strip out TF/IDF and then put it back in a
> sane manner.

I think the goal is a 0.1.0 release. Don't let the perfect become the
enemy of the good. If the current class naming for Match/Compiler/Query
is poor, but functioning, let's kick it down the road in favor of a
re-design, as Nate suggests. Backwards-compat-forever is not our friend
in this regard.


-- 
Peter Karman  .  http://peknet.com/  .  peter@peknet.com

Mime
View raw message