incubator-libcloud mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tomaz Muraus <to...@cloudkick.com>
Subject Re: [libcloud] Trouble naming an AWS EC2 node...
Date Fri, 08 Apr 2011 23:08:26 GMT
Hm, I didn't know that.

In this case, I think we should add a name tag after creating a node so
it's consistent with other drivers.

On Fri, Apr 8, 2011 at 10:47 PM, Paul Querna <paul@querna.org> wrote:

> Actually since.. late last year when they added Tagging to their
> nodes, you can set the tag 'name' and it shows up in their management
> console as the name.
>
> On Fri, Apr 8, 2011 at 4:56 AM, Tomaz Muraus <tomaz@cloudkick.com> wrote:
> > Hello,
> >
> > You are correct - Amazon driver ignores the name attribute because their
> API
> > doesn't support setting a name.
> >
> > In any case, I think we should document this somewhere.
> >
> > On Fri, Apr 8, 2011 at 9:15 AM, Sam's Lists <samslists@gmail.com> wrote:
> >
> >> I'm able to create an ec2 node without an issue, except for the fact
> that
> >> when I pass in a name doing something like this:
> >>
> >> _Conn.create_node(name="foobar", image=use_image, size=use_size,
> >> ex_keyname="ec2-a")
> >>
> >> the name seems to be completely ignored.
> >>
> >> Is this the excepted behavior, or am I doing something wrong?
> >>
> >> This is libcloud 0.4.2 under Python 2.6 using Ubuntu 10.10 (called as a
> >> library through Fabric).
> >>
> >> Thanks!
> >>
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message