incubator-libcloud mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jed Smith (JIRA)" <j...@apache.org>
Subject [libcloud] [jira] Assigned: (LIBCLOUD-40) Different drivers use different types for Node.id
Date Thu, 05 Aug 2010 19:46:16 GMT

     [ https://issues.apache.org/jira/browse/LIBCLOUD-40?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jed Smith reassigned LIBCLOUD-40:
---------------------------------

    Assignee: Jed Smith

> Different drivers use different types for Node.id
> -------------------------------------------------
>
>                 Key: LIBCLOUD-40
>                 URL: https://issues.apache.org/jira/browse/LIBCLOUD-40
>             Project: Libcloud
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 0.3.0
>         Environment: Any
>            Reporter: Steve Steiner
>            Assignee: Jed Smith
>
> The type of the 'id' field is different (<str> for rackspace, <int> for linode)
on Nodes returned from the list_images() call.
> I posted this to the mailing list and apparently there is not a standard type for 'id'
across drivers.  
> The unit tests seem to initialize nodes with integer 'id' as well.
> They should all use the same type for the id field -- presumably string since there are
providers that use strings that cannot be converted to ints.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message