incubator-kato-spec mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Pilkington <>
Subject Re: Final version of First Early Draft Review document
Date Thu, 10 Sep 2009 15:03:49 GMT
I'm currently reading through the EDR, so I'll post my comments ad-hoc
as I progress.

I'm looking at the CorruptData interface and wonder if the
getAddress() method should be renamed so that there isn't a clash with
other getAddress() methods. The reason for this is that if you wanted
to use generics at some point, then when an iterator wants to return a
corrupt object it would do so by returning one that additionally
implemented the CorruptData interface. However this could lead to a
clash e.g. ImageSymbol.getAddress() and CorruptData.getAddress() for
an object which was representing a corrupt ImageSymbol, and care would
need to be taken in order to ensure that you are working with the
correct method.

Given that CorruptData can be implemented by any object, would it be
better to ensure that it uses unique method/field names to prevent
confusion and increase code clarity ?

2009/8/21 Steve Poole <>:
> Hi all,   I've just posted the final version of the first EDR to the wiki
> here      I'm going to
> just check that I have everything in order process wise and then I'm going
> to send that doc to the JCP as our first EDR.
> If I've got all the JCP process stuff right then it will take a couple of
> days for it to appear on the JCP website here
> In theory that is the point where the specification becomes public but since
> we've always had an open approach that's not true for us.   I will be
> expecting comments from the public to appear on this mailing list.
> I'll point out again that the EDR is not complete - there are quite a few
> places where we need to resolve questions and expand the descriptions.
> Please take a look and comment  - or even provide some more words :-)
> Cheers
> Steve


Adam Pilkington

View raw message