incubator-kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neha Narkhede <neha.narkh...@gmail.com>
Subject Re: Kafka 0.8 trial version
Date Mon, 26 Nov 2012 22:49:20 GMT
0.8 is a backwards incompatible release, so this behaviour is intended
by design. We will write about the deployment plan in more detail, but
at a high level, here is what you would want to do -

1. Use a separate zookeeper namespace on your existing zk cluster, or
use a new zk cluster with the same namespace as your 0.7 Kafka
deployment.
2. Set up a 0.8 Kafka cluster per 0.7 Kafka cluster and run the
migration tool to copy data from 0.7 to 0.8.
3. Move all consumers to 0.8 Kafka cluster
4. Move all producers to 0.8 Kafka cluster

In general, for a topic, you want to ensure that all consumers have
moved to 0.8 cluster before the producers of the same topic.

Thanks,
Neha

On Mon, Nov 26, 2012 at 2:21 PM, Jason Rosenberg <jbr@squareup.com> wrote:
> Hmmm.....this sounds like a bug.  If I want to upgrade my kafka version,
> without changing my zookeeper deployment, will I have issues?  Will I have
> to manually go and reset all of the zookeeper data directories?
>
> Jason
>
> On Mon, Nov 26, 2012 at 1:45 PM, Chris Curtin <curtin.chris@gmail.com>wrote:
>>
>> One note for others: you need to remove your zookeeper configuration
>> (/opt/zookeeper/version-2 or /tmp/zookeeper/version-2) otherwise you get
>> tons of errors starting the brokers. Looks like the data stored in
>> zookeeper for 0.7.2 isn't compatible with 0.8.0.
>>
>>

Mime
View raw message